aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--keyserver/ChangeLog16
-rw-r--r--keyserver/gpgkeys_ldap.c2
-rwxr-xr-xkeyserver/gpgkeys_mailto.in2
3 files changed, 14 insertions, 6 deletions
diff --git a/keyserver/ChangeLog b/keyserver/ChangeLog
index de46f5f70..a6e482a9c 100644
--- a/keyserver/ChangeLog
+++ b/keyserver/ChangeLog
@@ -1,3 +1,10 @@
+2004-02-18 David Shaw <[email protected]>
+
+ * gpgkeys_ldap.c (ldap_to_gpg_err): Make sure that
+ LDAP_OPT_ERROR_NUMBER is defined before we use it.
+
+ * gpgkeys_mailto.in: Fix VERSION number.
+
2004-01-13 Werner Koch <[email protected]>
* gpgkeys_hkp.c (send_key): Add a content type.
@@ -16,7 +23,8 @@
* gpgkeys_hkp.c (send_key, get_key, main): Work with new HTTP code
that passes the proxy in from the outside. If the command file
sends a proxy, use it. If it sends "http-proxy" with no
- arguments, use $http_proxy from the environment.
+ arguments, use $http_proxy from the environment. Suggested by
+ Christian Biere.
2003-12-28 Stefan Bellon <[email protected]>
@@ -41,7 +49,7 @@
* gpgkeys_hkp.c, gpgkeys_ldap.c: #include <getopt.h> if it is
available. Also include extern references for optarg and optind
since there is no guarantee that any header file will include
- them. Standards? We don't need no stinkin' standards
+ them. Standards? We don't need no stinkin' standards.
* Makefile.am: Use @GETOPT@ to pull in libiberty on those
platforms that need it.
@@ -395,7 +403,8 @@
gpgkeys_mailto (email keyserver helper)
- Copyright 1998, 1999, 2000, 2001, 2002 Free Software Foundation, Inc.
+ Copyright 1998, 1999, 2000, 2001, 2002, 2003,
+ 2004 Free Software Foundation, Inc.
This file is free software; as a special exception the author gives
unlimited permission to copy and/or distribute it, with or without
@@ -404,4 +413,3 @@
This file is distributed in the hope that it will be useful, but
WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
- \ No newline at end of file
diff --git a/keyserver/gpgkeys_ldap.c b/keyserver/gpgkeys_ldap.c
index 8dd0f0244..06e5f02bc 100644
--- a/keyserver/gpgkeys_ldap.c
+++ b/keyserver/gpgkeys_ldap.c
@@ -86,7 +86,7 @@ ldap_err_to_gpg_err(int err)
int
ldap_to_gpg_err(LDAP *ld)
{
-#if defined(HAVE_LDAP_GET_OPTION)
+#if defined(HAVE_LDAP_GET_OPTION) && defined(LDAP_OPT_ERROR_NUMBER)
int err;
diff --git a/keyserver/gpgkeys_mailto.in b/keyserver/gpgkeys_mailto.in
index 4e48ba479..0691e4c46 100755
--- a/keyserver/gpgkeys_mailto.in
+++ b/keyserver/gpgkeys_mailto.in
@@ -114,7 +114,7 @@ while(<STDIN>)
# Send response
-print "VERSION 0\n";
+print "VERSION 1\n";
print "OPTION OUTOFBAND\n\n";
# Email keyservers get and search the same way