aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--keyserver/ChangeLog8
-rw-r--r--keyserver/Makefile.am16
-rw-r--r--keyserver/gpgkeys_curl.c8
-rw-r--r--keyserver/gpgkeys_hkp.c6
-rw-r--r--keyserver/ksutil.c6
-rw-r--r--keyserver/ksutil.h7
6 files changed, 21 insertions, 30 deletions
diff --git a/keyserver/ChangeLog b/keyserver/ChangeLog
index 98cf0c0c9..1870e6f74 100644
--- a/keyserver/ChangeLog
+++ b/keyserver/ChangeLog
@@ -1,3 +1,11 @@
+2006-04-26 David Shaw <[email protected]>
+
+ * Makefile.am: Don't build gpgkeys_http or gpgkeys_(old)hkp any
+ longer as this is done via curl or fake-curl.
+
+ * ksutil.h, ksutil.c, gpgkeys_hkp.c, gpgkeys_curl.c: Minor
+ #include tweaks as FAKE_CURL is no longer meaningful.
+
2006-04-10 David Shaw <[email protected]>
* gpgkeys_ldap.c (ldap_quote, get_name, search_key): LDAP-quote
diff --git a/keyserver/Makefile.am b/keyserver/Makefile.am
index e57d969f6..72572de2c 100644
--- a/keyserver/Makefile.am
+++ b/keyserver/Makefile.am
@@ -1,4 +1,4 @@
-# Copyright (C) 2001, 2002, 2004, 2005 Free Software Foundation, Inc.
+# Copyright (C) 2001, 2002, 2004, 2005, 2006 Free Software Foundation, Inc.
#
# This file is part of GnuPG.
#
@@ -19,18 +19,17 @@
## Process this file with automake to produce Makefile.in
INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/intl
-EXTRA_PROGRAMS = gpgkeys_ldap gpgkeys_hkp gpgkeys_http gpgkeys_finger gpgkeys_curl
+EXTRA_PROGRAMS = gpgkeys_ldap gpgkeys_hkp gpgkeys_finger gpgkeys_curl
EXTRA_SCRIPTS = gpgkeys_mailto
gpglibexecdir = $(libexecdir)/@PACKAGE@
-gpglibexec_PROGRAMS = @GPGKEYS_LDAP@ @GPGKEYS_HKP@ @GPGKEYS_FINGER@ @GPGKEYS_HTTP@ @GPGKEYS_CURL@
+gpglibexec_PROGRAMS = @GPGKEYS_LDAP@ @GPGKEYS_HKP@ @GPGKEYS_FINGER@ @GPGKEYS_CURL@
gpglibexec_SCRIPTS = @GPGKEYS_MAILTO@
noinst_SCRIPTS = gpgkeys_test
gpgkeys_ldap_SOURCES = gpgkeys_ldap.c ksutil.c ksutil.h
-gpgkeys_hkp_SOURCES = ksutil.c ksutil.h
-gpgkeys_http_SOURCES = gpgkeys_http.c ksutil.c ksutil.h
+gpgkeys_hkp_SOURCES = gpgkeys_hkp.c ksutil.c ksutil.h
gpgkeys_finger_SOURCES = gpgkeys_finger.c ksutil.c ksutil.h
gpgkeys_curl_SOURCES = gpgkeys_curl.c ksutil.c ksutil.h
@@ -39,11 +38,8 @@ other_libs = $(LIBICONV) $(LIBINTL) $(CAPLIBS)
gpgkeys_ldap_CPPFLAGS = @LDAP_CPPFLAGS@
gpgkeys_ldap_LDADD = ../util/libutil.a @LDAPLIBS@ @NETLIBS@ $(other_libs) @GETOPT@ @W32LIBS@
-gpgkeys_http_LDADD = ../util/libutil.a @NETLIBS@ @SRVLIBS@ $(other_libs) @GETOPT@ @W32LIBS@
gpgkeys_finger_LDADD = ../util/libutil.a @NETLIBS@ $(other_libs) @GETOPT@ @W32LIBS@
-if WITH_CURL
-gpgkeys_hkp_SOURCES += gpgkeys_hkp.c
if FAKE_CURL
gpgkeys_curl_SOURCES += curl-shim.c curl-shim.h
gpgkeys_curl_LDADD = ../util/libutil.a @NETLIBS@ @SRVLIBS@ $(other_libs) @GETOPT@ @W32LIBS@
@@ -55,7 +51,3 @@ gpgkeys_curl_LDADD = @LIBCURL@ @GETOPT@
gpgkeys_hkp_CPPFLAGS = @LIBCURL_CPPFLAGS@
gpgkeys_hkp_LDADD = @LIBCURL@ @GETOPT@
endif
-else
-gpgkeys_hkp_SOURCES += gpgkeys_oldhkp.c
-gpgkeys_hkp_LDADD = ../util/libutil.a @NETLIBS@ @SRVLIBS@ $(other_libs) @GETOPT@ @W32LIBS@
-endif
diff --git a/keyserver/gpgkeys_curl.c b/keyserver/gpgkeys_curl.c
index bd26d7849..9e4b56729 100644
--- a/keyserver/gpgkeys_curl.c
+++ b/keyserver/gpgkeys_curl.c
@@ -1,5 +1,5 @@
/* gpgkeys_curl.c - fetch a key via libcurl
- * Copyright (C) 2004, 2005 Free Software Foundation, Inc.
+ * Copyright (C) 2004, 2005, 2006 Free Software Foundation, Inc.
*
* This file is part of GnuPG.
*
@@ -28,10 +28,10 @@
#ifdef HAVE_GETOPT_H
#include <getopt.h>
#endif
-#ifdef FAKE_CURL
-#include "curl-shim.h"
-#else
+#ifdef HAVE_LIBCURL
#include <curl/curl.h>
+#else
+#include "curl-shim.h"
#endif
#include "keyserver.h"
#include "ksutil.h"
diff --git a/keyserver/gpgkeys_hkp.c b/keyserver/gpgkeys_hkp.c
index c1160fa33..b3ebcf1a9 100644
--- a/keyserver/gpgkeys_hkp.c
+++ b/keyserver/gpgkeys_hkp.c
@@ -28,10 +28,10 @@
#ifdef HAVE_GETOPT_H
#include <getopt.h>
#endif
-#ifdef FAKE_CURL
-#include "curl-shim.h"
-#else
+#ifdef HAVE_LIBCURL
#include <curl/curl.h>
+#else
+#include "curl-shim.h"
#endif
#include "keyserver.h"
#include "ksutil.h"
diff --git a/keyserver/ksutil.c b/keyserver/ksutil.c
index 9bd697fff..64912bb2d 100644
--- a/keyserver/ksutil.c
+++ b/keyserver/ksutil.c
@@ -1,5 +1,5 @@
/* ksutil.c - general keyserver utility functions
- * Copyright (C) 2004, 2005 Free Software Foundation, Inc.
+ * Copyright (C) 2004, 2005, 2006 Free Software Foundation, Inc.
*
* This file is part of GnuPG.
*
@@ -29,10 +29,8 @@
#ifdef HAVE_LIBCURL
#include <curl/curl.h>
#else
-#ifdef FAKE_CURL
#include "curl-shim.h"
#endif
-#endif
#include "keyserver.h"
#include "ksutil.h"
@@ -380,7 +378,6 @@ classify_ks_search(const char **search)
}
}
-#if defined (HAVE_LIBCURL) || defined (FAKE_CURL)
int
curl_err_to_gpg_err(CURLcode error)
{
@@ -541,4 +538,3 @@ curl_writer_finalize(struct curl_writer_ctx *ctx)
ctx->flags.done=1;
}
}
-#endif
diff --git a/keyserver/ksutil.h b/keyserver/ksutil.h
index 0ef14f595..16c1ebf88 100644
--- a/keyserver/ksutil.h
+++ b/keyserver/ksutil.h
@@ -1,5 +1,5 @@
/* ksutil.h
- * Copyright (C) 2004, 2005 Free Software Foundation, Inc.
+ * Copyright (C) 2004, 2005, 2006 Free Software Foundation, Inc.
*
* This file is part of GNUPG.
*
@@ -25,10 +25,8 @@
#ifdef HAVE_LIBCURL
#include <curl/curl.h>
#else
-#ifdef FAKE_CURL
#include "curl-shim.h"
#endif
-#endif
/* MAX_LINE must be at least 1 larger than the largest item we expect
to receive, including the name tag ("COMMAND", "PORT", etc) and
@@ -107,7 +105,6 @@ const char *ks_action_to_string(enum ks_action action);
void print_nocr(FILE *stream,const char *str);
enum ks_search_type classify_ks_search(const char **search);
-#if defined (HAVE_LIBCURL) || defined (FAKE_CURL)
int curl_err_to_gpg_err(CURLcode error);
struct curl_writer_ctx
@@ -130,6 +127,4 @@ struct curl_writer_ctx
size_t curl_writer(const void *ptr,size_t size,size_t nmemb,void *cw_ctx);
void curl_writer_finalize(struct curl_writer_ctx *ctx);
-#endif
-
#endif /* !_KSUTIL_H_ */