aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ChangeLog4
-rw-r--r--NEWS2
-rw-r--r--configure.ac18
3 files changed, 17 insertions, 7 deletions
diff --git a/ChangeLog b/ChangeLog
index 2471770bc..77ae1dbe5 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,8 @@
2003-04-15 Werner Koch <[email protected]>
- * acinclude.m4 (GNUPG_CHECK_ENDIAN): Fix quoting of r.e. using
+ * configure.ac (HAVE_DOSISH_SYSTEM): New automake conditional.
+
+ * acinclude.m4 (GNUPG_CHECK_ENDIAN): Fixed quoting of r.e. using
quadrigraphs.
2003-04-08 Werner Koch <[email protected]>
diff --git a/NEWS b/NEWS
index b681cc4ab..57ff1b9c5 100644
--- a/NEWS
+++ b/NEWS
@@ -55,6 +55,8 @@ Noteworthy changes in version 1.3.2 (unreleased)
* Add read-only support for the SHA-256 hash, and optional
read-only support for the SHA-384 and SHA-512 hashes.
+ * New option --enable-progress-filter for use with frontends.
+
Noteworthy changes in version 1.3.1 (2002-11-12)
------------------------------------------------
diff --git a/configure.ac b/configure.ac
index b967d4b88..282ab5019 100644
--- a/configure.ac
+++ b/configure.ac
@@ -353,6 +353,7 @@ MPI_OPT_FLAGS=""
try_gettext=yes
+have_dosish_system=no
case "${target}" in
*-*-mingw32*)
# special stuff for Windoze NT
@@ -361,21 +362,18 @@ case "${target}" in
[set this to limit filenames to the 8.3 format])
AC_DEFINE(HAVE_DRIVE_LETTERS,1,
[defined if we must run on a stupid file system])
- AC_DEFINE(HAVE_DOSISH_SYSTEM,1,
- [defined if we run on some of the PCDOS like systems
- (DOS, Windoze. OS/2) with special properties like
- no file modes])
AC_DEFINE(USE_SIMPLE_GETTEXT,1,
[because the Unix gettext has too much overhead on
MingW32 systems and these systems lack Posix functions,
we use a simplified version of gettext])
+ have_dosish_system=yes
try_gettext="no"
;;
i?86-emx-os2 | i?86-*-os2*emx )
# OS/2 with the EMX environment
ac_cv_have_dev_random=no
AC_DEFINE(HAVE_DRIVE_LETTERS)
- AC_DEFINE(HAVE_DOSISH_SYSTEM)
+ have_dosish_system=yes
try_gettext="no"
;;
@@ -383,7 +381,7 @@ case "${target}" in
# DOS with the DJGPP environment
ac_cv_have_dev_random=no
AC_DEFINE(HAVE_DRIVE_LETTERS)
- AC_DEFINE(HAVE_DOSISH_SYSTEM)
+ have_dosish_system=yes
try_gettext="no"
;;
@@ -420,6 +418,14 @@ case "${target}" in
;;
esac
+if test "$have_dosish_system" = yes; then
+ AC_DEFINE(HAVE_DOSISH_SYSTEM,1,
+ [defined if we run on some of the PCDOS like systems
+ (DOS, Windoze. OS/2) with special properties like
+ no file modes])
+fi
+AM_CONDITIONAL(HAVE_DOSISH_SYSTEM, test "$have_dosish_system" = yes)
+
AC_SUBST(MPI_OPT_FLAGS)
GNUPG_SYS_SYMBOL_UNDERSCORE