aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--agent/command-ssh.c3
-rw-r--r--configure.ac2
2 files changed, 4 insertions, 1 deletions
diff --git a/agent/command-ssh.c b/agent/command-ssh.c
index 213f3f9f7..e0b723839 100644
--- a/agent/command-ssh.c
+++ b/agent/command-ssh.c
@@ -47,6 +47,9 @@
#ifdef HAVE_SYS_UCRED_H
#include <sys/ucred.h>
#endif
+#ifdef HAVE_UCRED_H
+#include <ucred.h>
+#endif
#include "agent.h"
diff --git a/configure.ac b/configure.ac
index 424ce7be1..420af92f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1278,7 +1278,7 @@ AC_HEADER_STDC
AC_CHECK_HEADERS([string.h unistd.h langinfo.h termio.h locale.h getopt.h \
pty.h utmp.h pwd.h inttypes.h signal.h sys/select.h \
stdint.h signal.h util.h libutil.h termios.h \
- sys/ucred.h sys/sysmacros.h sys/mkdev.h])
+ ucred.h sys/ucred.h sys/sysmacros.h sys/mkdev.h])
AC_HEADER_TIME