aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/ChangeLog4
-rw-r--r--common/simple-pwquery.c2
2 files changed, 5 insertions, 1 deletions
diff --git a/common/ChangeLog b/common/ChangeLog
index e9bb42a57..f5c5c0982 100644
--- a/common/ChangeLog
+++ b/common/ChangeLog
@@ -1,3 +1,7 @@
+2005-04-11 Marcus Brinkmann <[email protected]>
+
+ * simple-pwquery.c (simple_pwquery): Use spwq_secure_free.
+
2005-03-03 Werner Koch <[email protected]>
* Makefile.am (AM_CFLAGS): Added PTH_CFLAGS. Noted by Kazu Yamamoto.
diff --git a/common/simple-pwquery.c b/common/simple-pwquery.c
index 37a45816c..8a027e799 100644
--- a/common/simple-pwquery.c
+++ b/common/simple-pwquery.c
@@ -541,7 +541,7 @@ simple_pwquery (const char *cacheid,
if (fd != -1)
close (fd);
if (pw)
- spwq_free (pw);
+ spwq_secure_free (pw);
return result;
}