aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mpi/ChangeLog4
-rw-r--r--mpi/Makefile.am2
2 files changed, 5 insertions, 1 deletions
diff --git a/mpi/ChangeLog b/mpi/ChangeLog
index a595bc171..d362dd714 100644
--- a/mpi/ChangeLog
+++ b/mpi/ChangeLog
@@ -1,3 +1,7 @@
+2004-10-12 Werner Koch <[email protected]>
+
+ * Makefile.am (.S.o): Include MPI_SFLAGS. This is our bug 145.
+
2004-09-29 David Shaw <[email protected]>
* mpicoder.c (mpi_read): If we must fail due to a oversize
diff --git a/mpi/Makefile.am b/mpi/Makefile.am
index 10b1988d5..798a4d1dd 100644
--- a/mpi/Makefile.am
+++ b/mpi/Makefile.am
@@ -73,7 +73,7 @@ libmpi_a_LIBADD = $(common_asm_objects) @MPI_EXTRA_ASM_OBJS@
# work and add one to cpp .S files
.S.o:
$(CPP) $(INCLUDES) $(DEFS) $< | grep -v '^#' > _$*.s
- $(COMPILE) -c _$*.s
+ $(COMPILE) $(ASFLAGS) -c _$*.s
mv -f _$*.o $*.o
.S.lo: