aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/ChangeLog5
-rw-r--r--common/Makefile.am8
-rw-r--r--dirmngr/ChangeLog2
-rw-r--r--dirmngr/Makefile.am2
-rw-r--r--tools/ChangeLog4
-rw-r--r--tools/Makefile.am14
6 files changed, 24 insertions, 11 deletions
diff --git a/common/ChangeLog b/common/ChangeLog
index b4c79e234..281dd64c6 100644
--- a/common/ChangeLog
+++ b/common/ChangeLog
@@ -1,3 +1,8 @@
+2010-08-13 Werner Koch <[email protected]>
+
+ * Makefile.am (audit-events.h, status-codes.h): Fix srcdir problem
+ amd depend on Makefile.am instead of Makefile.
+
2010-08-12 Werner Koch <[email protected]>
* sysutils.c (gnupg_remove) [W32CE]: Fix returned error.
diff --git a/common/Makefile.am b/common/Makefile.am
index 26c8233e4..110fc5f58 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -139,16 +139,16 @@ if MAINTAINER_MODE
# is a distributed built source. If we would not do that we may end
# up with two files and then it is not clear which version of the
# files will be picked up.
-audit-events.h: Makefile mkstrtable.awk exaudit.awk audit.h
+audit-events.h: Makefile.am mkstrtable.awk exaudit.awk audit.h
$(AWK) -f $(srcdir)/exaudit.awk $(srcdir)/audit.h \
| $(AWK) -f $(srcdir)/mkstrtable.awk -v textidx=3 -v nogettext=1 \
- -v namespace=eventstr_ > $(srcdir)/$@
+ -v namespace=eventstr_ > $(srcdir)/audit-events.h
# Create the status-codes.h include file from status.h
-status-codes.h: Makefile mkstrtable.awk exstatus.awk status.h
+status-codes.h: Makefile.am mkstrtable.awk exstatus.awk status.h
$(AWK) -f $(srcdir)/exstatus.awk $(srcdir)/status.h \
| $(AWK) -f $(srcdir)/mkstrtable.awk -v textidx=3 -v nogettext=1 \
- -v namespace=statusstr_ > $(srcdir)/$@
+ -v namespace=statusstr_ > $(srcdir)/status-codes.h
endif
#
diff --git a/dirmngr/ChangeLog b/dirmngr/ChangeLog
index af48260b3..3afd1372a 100644
--- a/dirmngr/ChangeLog
+++ b/dirmngr/ChangeLog
@@ -1,5 +1,7 @@
2010-08-13 Werner Koch <[email protected]>
+ * Makefile.am (dirmngr_SOURCES): Add w32-ldap-help.h.
+
* dirmngr_ldap.c (fetch_ldap): Call ldap_unbind.
* w32-ldap-help.h: New.
diff --git a/dirmngr/Makefile.am b/dirmngr/Makefile.am
index 176374901..0adb822c3 100644
--- a/dirmngr/Makefile.am
+++ b/dirmngr/Makefile.am
@@ -46,7 +46,7 @@ noinst_HEADERS = dirmngr.h crlcache.h crlfetch.h misc.h
dirmngr_SOURCES = dirmngr.c dirmngr.h server.c crlcache.c crlfetch.c \
ldapserver.h ldapserver.c certcache.c certcache.h \
- cdb.h cdblib.c ldap.c misc.c dirmngr-err.h \
+ cdb.h cdblib.c ldap.c misc.c dirmngr-err.h w32-ldap-help.h \
ocsp.c ocsp.h validate.c validate.h ldap-wrapper.h $(ldap_url)
if USE_LDAPWRAPPER
diff --git a/tools/ChangeLog b/tools/ChangeLog
index c50e3a3bc..7bfb2abcd 100644
--- a/tools/ChangeLog
+++ b/tools/ChangeLog
@@ -1,3 +1,7 @@
+2010-08-13 Werner Koch <[email protected]>
+
+ * Makefile.am (gpgkey2ssh_LDADD): Add NETLIBS.
+
2010-08-11 Werner Koch <[email protected]>
* gpgtar-create.c (gpgtar_create): Allow "-" for stdout in
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 73913de44..5294b8ce6 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -79,14 +79,15 @@ endif
gpgsplit_LDADD = $(common_libs) \
$(LIBGCRYPT_LIBS) $(GPG_ERROR_LIBS) \
- $(ZLIBS) $(LIBINTL) $(LIBICONV)
+ $(ZLIBS) $(LIBINTL) $(NETLIBS) $(LIBICONV)
gpgconf_SOURCES = gpgconf.c gpgconf.h gpgconf-comp.c no-libgcrypt.c
# common sucks in gpg-error, will they, nil they (some compilers
# do not eliminate the supposed-to-be-unused-inline-functions).
gpgconf_LDADD = $(common_libs) $(opt_libassuan_libs) \
- $(LIBINTL) $(GPG_ERROR_LIBS) $(LIBICONV) $(W32SOCKLIBS)
+ $(LIBINTL) $(GPG_ERROR_LIBS) $(NETLIBS) \
+ $(LIBICONV) $(W32SOCKLIBS)
gpgparsemail_SOURCES = gpgparsemail.c rfc822parse.c rfc822parse.h
gpgparsemail_LDADD =
@@ -94,7 +95,7 @@ gpgparsemail_LDADD =
symcryptrun_SOURCES = symcryptrun.c
symcryptrun_LDADD = $(LIBUTIL_LIBS) $(common_libs) $(pwquery_libs) \
$(LIBGCRYPT_LIBS) $(GPG_ERROR_LIBS) $(LIBINTL) \
- $(LIBICONV) $(W32SOCKLIBS)
+ $(LIBICONV) $(NETLIBS) $(W32SOCKLIBS)
watchgnupg_SOURCES = watchgnupg.c
watchgnupg_LDADD = $(NETLIBS)
@@ -111,14 +112,15 @@ gpgkey2ssh_CFLAGS = $(LIBGCRYPT_CFLAGS) $(GPG_ERROR_CFLAGS)
# common via use of BUG() in an inline function, which
# some compilers do not eliminate.
gpgkey2ssh_LDADD = $(common_libs) \
- $(LIBGCRYPT_LIBS) $(GPG_ERROR_LIBS) $(LIBINTL) $(LIBICONV)
+ $(LIBGCRYPT_LIBS) $(GPG_ERROR_LIBS) $(LIBINTL) $(LIBICONV) \
+ $(NETLIBS)
endif
if !DISABLE_REGEX
gpg_check_pattern_SOURCES = gpg-check-pattern.c
gpg_check_pattern_CFLAGS = $(LIBGCRYPT_CFLAGS) $(GPG_ERROR_CFLAGS)
gpg_check_pattern_LDADD = $(common_libs) $(LIBGCRYPT_LIBS) $(GPG_ERROR_LIBS) \
- $(LIBINTL) $(LIBICONV) $(W32SOCKLIBS)
+ $(LIBINTL) $(NETLIBS) $(LIBICONV) $(W32SOCKLIBS)
endif
gpgtar_SOURCES = \
@@ -129,7 +131,7 @@ gpgtar_SOURCES = \
no-libgcrypt.c
gpgtar_CFLAGS = $(GPG_ERROR_CFLAGS) $(PTH_CFLAGS)
#gpgtar_LDADD = $(commonpth_libs) $(PTH_LIBS) $(GPG_ERROR_LIBS)
-gpgtar_LDADD = $(common_libs) $(GPG_ERROR_LIBS) $(W32SOCKLIBS)
+gpgtar_LDADD = $(common_libs) $(GPG_ERROR_LIBS) $(NETLIBS) $(W32SOCKLIBS)
# Make sure that all libs are build before we use them. This is