aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--agent/ChangeLog5
-rw-r--r--agent/Makefile.am5
2 files changed, 8 insertions, 2 deletions
diff --git a/agent/ChangeLog b/agent/ChangeLog
index d0cb96857..0db76684a 100644
--- a/agent/ChangeLog
+++ b/agent/ChangeLog
@@ -1,3 +1,8 @@
+2006-09-06 Marcus Brinkmann <[email protected]>
+
+ * Makefile.am (AM_CFLAGS): Add $(GPG_ERR_CFLAGS).
+ (gpg_agent_LDADD): Replace -lgpg-error with $(GPG_ERROR_LIBS).
+
2006-09-06 Werner Koch <[email protected]>
* query.c: Renamed to ..
diff --git a/agent/Makefile.am b/agent/Makefile.am
index 0bccefab2..36baa9504 100644
--- a/agent/Makefile.am
+++ b/agent/Makefile.am
@@ -27,7 +27,8 @@ AM_CPPFLAGS = -I$(top_srcdir)/gl -I$(top_srcdir)/common -I$(top_srcdir)/intl
include $(top_srcdir)/am/cmacros.am
-AM_CFLAGS = $(LIBGCRYPT_CFLAGS) $(LIBASSUAN_CFLAGS) $(PTH_CFLAGS)
+AM_CFLAGS = $(LIBGCRYPT_CFLAGS) $(LIBASSUAN_CFLAGS) $(GPG_ERROR_CFLAGS) \
+ $(PTH_CFLAGS)
gpg_agent_SOURCES = \
gpg-agent.c agent.h \
@@ -48,7 +49,7 @@ gpg_agent_SOURCES = \
gpg_agent_LDADD = ../jnlib/libjnlib.a ../common/libcommon.a ../gl/libgnu.a \
$(LIBGCRYPT_LIBS) $(PTH_LIBS) $(LIBASSUAN_LIBS) \
- -lgpg-error @LIBINTL@ $(NETLIBS)
+ $(GPG_ERROR_LIBS) @LIBINTL@ $(NETLIBS)
gpg_protect_tool_SOURCES = \
protect-tool.c \