aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--scripts/ChangeLog8
-rwxr-xr-xscripts/convert-from-10652
-rw-r--r--scripts/distfiles3
-rw-r--r--scripts/gnupg.spec.in6
4 files changed, 68 insertions, 1 deletions
diff --git a/scripts/ChangeLog b/scripts/ChangeLog
index 8851ad87a..51b030057 100644
--- a/scripts/ChangeLog
+++ b/scripts/ChangeLog
@@ -1,3 +1,11 @@
+2002-12-01 David Shaw <[email protected]>
+
+ * distfiles, gnupg.spec.in: Include convert-from-106.
+
+ * convert-from-106: Script to automate the 1.0.6->later
+ conversion. It marks all secret keys as ultimately trusted, adds
+ the signature caches, and checks the trustdb.
+
2002-11-13 David Shaw <[email protected]>
* mk-w32-dist: Don't use iconv for pl.po. From Werner on stable
diff --git a/scripts/convert-from-106 b/scripts/convert-from-106
new file mode 100755
index 000000000..b8225d28e
--- /dev/null
+++ b/scripts/convert-from-106
@@ -0,0 +1,52 @@
+#!/bin/sh
+# Copyright (C) 2002 Free Software Foundation, Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+gpg="../g10/gpg --no-greeting --no-secmem-warning";
+
+echo "This script converts your public keyring and trustdb from GnuPG"
+echo "1.0.6 or earlier to the 1.0.7 and later format."
+
+echo "If you have already done this, there is no harm (but no point)"
+echo "in doing it again."
+
+echo -n "Continue? (y/N)"
+
+read answer
+
+if test "x$answer" != "xy" ; then
+ exit 0
+fi
+
+echo
+echo "Marking your keys as ultimately trusted"
+for key in `$gpg --with-colons --list-secret-keys | grep sec: | cut -d: -f5`
+do
+ $gpg --trusted-key $key --with-colons --list-keys $key > /dev/null 2>&1
+ echo -n "."
+done
+echo
+
+echo
+echo "Adding signature caches"
+$gpg --rebuild-keydb-caches
+
+echo
+echo "Checking trustdb"
+$gpg --check-trustdb
+
+echo
+echo "Done!"
diff --git a/scripts/distfiles b/scripts/distfiles
index 0e3d55801..c0e87b1f6 100644
--- a/scripts/distfiles
+++ b/scripts/distfiles
@@ -3,4 +3,5 @@ build-w32
gnupg.spec.in
autogen.sh
mk-gpg-texi
-mk-w32-dist \ No newline at end of file
+mk-w32-dist
+convert-from-106
diff --git a/scripts/gnupg.spec.in b/scripts/gnupg.spec.in
index e62bc817e..4f0d41fcc 100644
--- a/scripts/gnupg.spec.in
+++ b/scripts/gnupg.spec.in
@@ -24,13 +24,18 @@ Provides: gpg openpgp
BuildRoot: /tmp/rpmbuild_%{name}
%changelog
+* Sat Nov 30 2002 David Shaw <[email protected]>
+- Add convert-from-106 script
+
* Sat Oct 26 2002 David Shaw <[email protected]>
- Use new path for keyserver helpers.
- /usr/lib is no longer used for cipher/hash plugins.
- Include gpgv, gpgsplit, and the new gnupg.7 man page.
+
* Fri Apr 19 2002 David Shaw <[email protected]>
- Removed OPTIONS and pubring.asc - no longer used
- Added doc/samplekeys.asc
+
* Sun Mar 31 2002 David Shaw <[email protected]>
- Added the gpgkeys_xxx keyserver helpers.
- Added a * to catch variations on the basic gpg man page (gpg, gpgv).
@@ -165,6 +170,7 @@ make install-strip prefix=$RPM_BUILD_ROOT/usr
%doc %attr (-,root,root) doc/HACKING
%doc %attr (-,root,root) doc/OpenPGP
%doc %attr (-,root,root) doc/samplekeys.asc
+%doc %attr (0755,root,root) scripts/convert-from-106
%attr (-,root,root) /usr/man/man1/gpg*.1*
%attr (-,root,root) /usr/man/man7/gnupg.7*