aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ChangeLog8
-rw-r--r--README4
-rw-r--r--configure.ac21
3 files changed, 27 insertions, 6 deletions
diff --git a/ChangeLog b/ChangeLog
index 77ae1dbe5..d20ff178b 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,11 @@
+2003-04-23 David Shaw <[email protected]>
+
+ * configure.ac: Big warning that TIGER/192 is being removed from
+ the standard, and make it disabled by default.
+
+ * README: Put back proper copyright line. Remove mention of
+ TIGER/192.
+
2003-04-15 Werner Koch <[email protected]>
* configure.ac (HAVE_DOSISH_SYSTEM): New automake conditional.
diff --git a/README b/README
index da80e4c12..00d25a96e 100644
--- a/README
+++ b/README
@@ -3,7 +3,8 @@
-------------------------------
Version 1.3.2
- Copyright 1998-2003 Free Software Foundation, Inc.
+ Copyright 1998, 1999, 2000, 2001, 2002, 2003
+ Free Software Foundation, Inc.
This file is free software; as a special exception the author gives
unlimited permission to copy and/or distribute it, with or without
@@ -528,7 +529,6 @@
--disable-blowfish
--disable-aes
--disable-twofish
- --disable-tiger192
--disable-sha256
--disable-sha512
Removes support for the selected algorithm. This
diff --git a/configure.ac b/configure.ac
index 282ab5019..7658c6f1c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -120,7 +120,7 @@ use_cast5=yes
use_blowfish=yes
use_aes=yes
use_twofish=yes
-use_tiger192=yes
+use_tiger192=no
use_sha256=yes
use_sha512=yes
use_exec=yes
@@ -132,7 +132,6 @@ AC_ARG_ENABLE(minimal,
use_blowfish=no
use_aes=no
use_twofish=no
- use_tiger192=no
use_sha256=no
use_sha512=no
use_exec=no)
@@ -200,13 +199,27 @@ if test x"$use_twofish" = xyes ; then
AC_DEFINE(USE_TWOFISH,1,[Define to include the TWOFISH cipher])
fi
-dnl TIGER192 is defined only after we confirm 64-bit support later
+dnl this is because the stable branch calls it just "tiger".
+AC_ARG_ENABLE(tiger,,use_tiger192=$enableval)
+
+dnl TIGER192 is actually defined only after we confirm 64-bit support
+dnl later
AC_MSG_CHECKING([whether to enable the TIGER/192 digest])
AC_ARG_ENABLE(tiger192,
- AC_HELP_STRING([--disable-tiger192],[disable the TIGER/192 digest]),
+ AC_HELP_STRING([--enable-tiger192],[enable the TIGER/192 digest]),
use_tiger192=$enableval)
AC_MSG_RESULT($use_tiger192)
+if test x"$use_tiger192" = xyes ; then
+ AC_MSG_WARN([[
+***
+*** The TIGER/192 digest is in the process of being removed from the
+*** OpenPGP standard. While it hasn't been removed from GnuPG yet, it
+*** will be removed in a future version. For the sake of future
+*** compatibility, please do not use this digest.
+***]])
+fi
+
AC_MSG_CHECKING([whether to enable the SHA-256 digest])
AC_ARG_ENABLE(sha256,
AC_HELP_STRING([--disable-sha256],[disable the SHA-256 digest]),