aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sm/ChangeLog5
-rw-r--r--sm/Makefile.am11
-rw-r--r--sm/gpgsm.c2
3 files changed, 12 insertions, 6 deletions
diff --git a/sm/ChangeLog b/sm/ChangeLog
index 7c4483335..77807d065 100644
--- a/sm/ChangeLog
+++ b/sm/ChangeLog
@@ -1,3 +1,8 @@
+2004-02-11 Werner Koch <[email protected]>
+
+ * Makefile.am (AM_CPPFLAGS): Pass directory constants via -D; this
+ will allow to override directory names at make time.
+
2004-02-02 Werner Koch <[email protected]>
* import.c (check_and_store): Import certificates even with
diff --git a/sm/Makefile.am b/sm/Makefile.am
index 6345573e5..1ac7cbe84 100644
--- a/sm/Makefile.am
+++ b/sm/Makefile.am
@@ -18,13 +18,14 @@
## Process this file with automake to produce Makefile.in
-localedir = $(datadir)/locale
-INCLUDES = -I../intl -DLOCALEDIR=\"$(localedir)\"
bin_PROGRAMS = gpgsm
-AM_CPPFLAGS = -I$(top_srcdir)/common -I$(top_srcdir)/intl \
- $(LIBGCRYPT_CFLAGS) $(LIBASSUAN_CFLAGS) $(KSBA_CFLAGS)
+AM_CFLAGS = $(LIBGCRYPT_CFLAGS) $(LIBASSUAN_CFLAGS) $(KSBA_CFLAGS)
+
+AM_CPPFLAGS = -I$(top_srcdir)/common -I$(top_srcdir)/intl
+include $(top_srcdir)/am/cmacros.am
+
gpgsm_SOURCES = \
gpgsm.c gpgsm.h \
@@ -52,4 +53,4 @@ gpgsm_SOURCES = \
gpgsm_LDADD = ../jnlib/libjnlib.a ../kbx/libkeybox.a ../common/libcommon.a \
$(LIBGCRYPT_LIBS) $(LIBASSUAN_LIBS) $(KSBA_LIBS) -lgpg-error \
- @INTLLIBS@
+ $(INTLLIBS)
diff --git a/sm/gpgsm.c b/sm/gpgsm.c
index c8d76afa9..d1da02c59 100644
--- a/sm/gpgsm.c
+++ b/sm/gpgsm.c
@@ -1480,7 +1480,7 @@ open_fwrite (const char *filename)
static void
run_protect_tool (int argc, char **argv)
{
- char *pgm = GNUPG_PROTECT_TOOL;
+ char *pgm = GNUPG_DEFAULT_PROTECT_TOOL;
char **av;
int i;