aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--g10/ChangeLog4
-rw-r--r--g10/Makefile.am2
-rw-r--r--g10/rmd160.h24
3 files changed, 29 insertions, 1 deletions
diff --git a/g10/ChangeLog b/g10/ChangeLog
index 2e921a0ed..b1c520301 100644
--- a/g10/ChangeLog
+++ b/g10/ChangeLog
@@ -1,3 +1,7 @@
+2008-12-12 Werner Koch <[email protected]>
+
+ * Makefile.am (common_source): Add rmd160.h.
+
2008-12-11 Werner Koch <[email protected]>
* sig-check.c (signature_check2): Change algorithm used to compute
diff --git a/g10/Makefile.am b/g10/Makefile.am
index f6f80e63e..9c829fa24 100644
--- a/g10/Makefile.am
+++ b/g10/Makefile.am
@@ -59,7 +59,7 @@ common_source = \
textfilter.c \
progress.c \
misc.c \
- rmd160.c \
+ rmd160.c rmd160.h \
options.h \
openfile.c \
keyid.c \
diff --git a/g10/rmd160.h b/g10/rmd160.h
new file mode 100644
index 000000000..551898b5d
--- /dev/null
+++ b/g10/rmd160.h
@@ -0,0 +1,24 @@
+/* rmd160.h
+ * Copyright (C) 2008 Free Software Foundation, Inc.
+ *
+ * This file is part of GnuPG.
+ *
+ * GnuPG is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * GnuPG is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, see <http://www.gnu.org/licenses/>.
+ */
+#ifndef G10_RMD160_H
+#define G10_RMD160_H
+
+void rmd160_hash_buffer (void *outbuf, const void *buffer, size_t length);
+
+#endif /*G10_RMD160_H*/