aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ChangeLog10
-rw-r--r--TODO3
-rw-r--r--acinclude.m418
-rw-r--r--configure.ac5
4 files changed, 29 insertions, 7 deletions
diff --git a/ChangeLog b/ChangeLog
index 75154d225..b4d3ef58a 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,11 @@
+2003-03-24 Werner Koch <[email protected]>
+
+ * acinclude.m4 (GNUPG_CHECK_ENDIAN): When crosscompiling assume
+ little only for Intel CPUs.
+
+ * configure.ac: Check for ranlib and ar. This is required for
+ cross compiling.
+
2003-03-11 David Shaw <[email protected]>
* configure.ac: Look for res_query so we can use DNS SRV, and add
@@ -1178,7 +1186,7 @@ Fri Feb 13 19:43:41 1998 Werner Koch ([email protected])
* Makefile.am: Likewise
- Copyright 1998, 1999, 2000, 2001, 2002 Free Software Foundation, Inc.
+ Copyright 1998,1999,2000,2001,2002,2003 Free Software Foundation, Inc.
This file is free software; as a special exception the author gives
unlimited permission to copy and/or distribute it, with or without
diff --git a/TODO b/TODO
index b013c6f81..8c000c538 100644
--- a/TODO
+++ b/TODO
@@ -96,6 +96,9 @@
* When presenting the result of a verification show the user ID with
the highest trust level first instead of the primary one.
+ * allow the use of option in gpg.conf.
+
+ * export-secret-subkey where only one of the subkeys gets exported.
Things we won't do
------------------
diff --git a/acinclude.m4 b/acinclude.m4
index 63704e4e4..89cfac06c 100644
--- a/acinclude.m4
+++ b/acinclude.m4
@@ -1,5 +1,5 @@
dnl macros to configure gnupg
-dnl Copyright (C) 1998, 1999, 2000, 2001 Free Software Foundation, Inc.
+dnl Copyright (C) 1998, 1999, 2000, 2001, 2003 Free Software Foundation, Inc.
dnl
dnl This file is part of GnuPG.
dnl
@@ -106,13 +106,21 @@ AC_DEFUN(GNUPG_CHECK_DOCBOOK_TO_TEXI,
])
-
dnl GNUPG_CHECK_ENDIAN
dnl define either LITTLE_ENDIAN_HOST or BIG_ENDIAN_HOST
dnl
define(GNUPG_CHECK_ENDIAN,
- [ if test "$cross_compiling" = yes; then
- AC_MSG_WARN(cross compiling; assuming little endianess)
+ [
+ tmp_assumed_endian=big
+ if test "$cross_compiling" = yes; then
+ case "$host_cpu" in
+ i[345678]* )
+ tmp_assumed_endian=little
+ ;;
+ *)
+ ;;
+ esac
+ AC_MSG_WARN(cross compiling; assuming $tmp_assumed_endian endianess)
fi
AC_MSG_CHECKING(endianess)
AC_CACHE_VAL(gnupg_cv_c_endian,
@@ -141,7 +149,7 @@ define(GNUPG_CHECK_ENDIAN,
}],
gnupg_cv_c_endian=little,
gnupg_cv_c_endian=big,
- gnupg_cv_c_endian=little
+ gnupg_cv_c_endian=$tmp_assumed_endian
)
fi
])
diff --git a/configure.ac b/configure.ac
index eba3602ac..03edddcae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,6 @@
dnl Configure.ac script for GnuPG
-dnl Copyright (C) 1998, 1999, 2000, 2001, 2002 Free Software Foundation, Inc.
+dnl Copyright (C) 1998, 1999, 2000, 2001, 2002,
+dnl 2003 Free Software Foundation, Inc.
dnl
dnl This file is part of GnuPG.
dnl
@@ -336,6 +337,8 @@ AM_MISSING_PROG(AUTOHEADER, autoheader, $missing_dir)
AM_MISSING_PROG(MAKEINFO, makeinfo, $missing_dir)
AC_PROG_CC
AC_PROG_CPP
+AC_PROG_RANLIB
+AC_CHECK_TOOL(AR, ar, :)
AC_PATH_PROG(PERL,"perl")
AC_ISC_POSIX
AC_SYS_LARGEFILE