aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--doc/Makefile.am1
-rw-r--r--doc/examples/debug.prf29
-rw-r--r--doc/examples/vsnfd.prf21
3 files changed, 51 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 0c2f2c9dc..0c7828497 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -22,6 +22,7 @@ AM_CPPFLAGS =
include $(top_srcdir)/am/cmacros.am
examples = examples/README examples/scd-event examples/trustlist.txt \
+ examples/vsnfd.prf examples/debug.prf \
examples/systemd-user/README \
examples/systemd-user/dirmngr.service \
examples/systemd-user/dirmngr.socket \
diff --git a/doc/examples/debug.prf b/doc/examples/debug.prf
new file mode 100644
index 000000000..f635fc88e
--- /dev/null
+++ b/doc/examples/debug.prf
@@ -0,0 +1,29 @@
+# debug.prf - Configure options for easier debugging -*- conf -*-
+#
+# Note that the actual debug options for each component need to be set
+# manually. Running the component with "--debug help" shows a list of
+# supported values. To watch the logs this command can be used:
+#
+# watchgnupg --time-only --force $(gpgconf --list-dirs socketdir)/S.log
+#
+
+[gpg]
+log-file socket://
+verbose
+#debug ipc
+
+[gpgsm]
+log-file socket://
+verbose
+#debug ipc
+
+[gpg-agent]
+log-file socket://
+verbose
+#debug ipc
+#debug-pinentry
+
+[dirmngr]
+log-file socket://
+verbose
+#debug ipc,dns
diff --git a/doc/examples/vsnfd.prf b/doc/examples/vsnfd.prf
new file mode 100644
index 000000000..17c6d4c90
--- /dev/null
+++ b/doc/examples/vsnfd.prf
@@ -0,0 +1,21 @@
+# vsnfd.prf - Configure options for the VS-NfD mode -*- conf -*-
+
+[gpg]
+compliance de-vs
+default-new-key-algo brainpoolP256r1+brainpoolP256r1
+
+[gpgsm]
+enable-crl-checks
+
+[gpg-agent]
+enable-extended-key-format
+default-cache-ttl 900
+max-cache-ttl [] 3600
+no-allow-mark-trusted
+no-allow-external-cache
+enforce-passphrase-constraints
+min-passphrase-len 9
+min-passphrase-nonalpha 0
+
+[dirmngr]
+allow-ocsp