aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--tests/openpgp/Makefile.am3
-rw-r--r--tests/openpgp/issue2929.scm32
2 files changed, 1 insertions, 34 deletions
diff --git a/tests/openpgp/Makefile.am b/tests/openpgp/Makefile.am
index 5cab3d55d..d1dd44914 100644
--- a/tests/openpgp/Makefile.am
+++ b/tests/openpgp/Makefile.am
@@ -96,8 +96,7 @@ XTESTS = \
issue2015.scm \
issue2346.scm \
issue2417.scm \
- issue2419.scm \
- issue2929.scm
+ issue2419.scm
# XXX: Currently, one cannot override automake's 'check' target. As a
# workaround, we avoid defining 'TESTS', thus automake will not emit
diff --git a/tests/openpgp/issue2929.scm b/tests/openpgp/issue2929.scm
deleted file mode 100644
index 44521bb2f..000000000
--- a/tests/openpgp/issue2929.scm
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/usr/bin/env gpgscm
-
-;; Copyright (C) 2017 g10 Code GmbH
-;;
-;; This file is part of GnuPG.
-;;
-;; GnuPG is free software; you can redistribute it and/or modify
-;; it under the terms of the GNU General Public License as published by
-;; the Free Software Foundation; either version 3 of the License, or
-;; (at your option) any later version.
-;;
-;; GnuPG is distributed in the hope that it will be useful,
-;; but WITHOUT ANY WARRANTY; without even the implied warranty of
-;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;; GNU General Public License for more details.
-;;
-;; You should have received a copy of the GNU General Public License
-;; along with this program; if not, see <http://www.gnu.org/licenses/>.
-
-(load (with-path "defs.scm"))
-(setup-environment)
-
-(catch (skip "Tofu not supported")
- (call-check `(,@gpg --trust-model=tofu --list-config)))
-
-;; Redefine GPG without --always-trust and TOFU trust model.
-(define gpg `(,(tool 'gpg) --no-permission-warning --trust-model=tofu))
-
-(info "Checking key creation with TOFU trust model (issue2929).")
-(call-check `(,@gpg --quick-generate-key [email protected]))
-(call-check `(,@gpg --sign gpg.conf))
-(call-check `(,@gpg --verify gpg.conf.gpg))