aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/Makefile.am5
-rw-r--r--dirmngr/Makefile.am3
2 files changed, 7 insertions, 1 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 439c29ba9..b955539c8 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -220,4 +220,7 @@ t_zb32_LDADD = $(t_common_ldadd)
# http tests
t_http_SOURCES = t-http.c
t_http_CFLAGS = $(t_common_cflags) $(LIBGNUTLS_CFLAGS)
-t_http_LDADD = $(libcommontls) $(t_common_ldadd) $(LIBGNUTLS_LIBS) $(DNSLIBS)
+t_http_LDADD = libcommontls.a $(t_common_ldadd) $(LIBGNUTLS_LIBS) $(DNSLIBS)
+
+# All programs should depend on the created libs.
+$(PROGRAMS) : libcommon.a libcommonpth.a libcommontls.a libcommontlsnpth.a
diff --git a/dirmngr/Makefile.am b/dirmngr/Makefile.am
index b5bef45f4..7e2449fc3 100644
--- a/dirmngr/Makefile.am
+++ b/dirmngr/Makefile.am
@@ -87,3 +87,6 @@ dirmngr_client_LDFLAGS = $(extra_bin_ldflags)
no-libgcrypt.c : $(top_srcdir)/tools/no-libgcrypt.c
cat $(top_srcdir)/tools/no-libgcrypt.c > no-libgcrypt.c
+
+
+$(PROGRAMS) : $(libcommon) $(libcommonpth) $(libcommontls) $(libcommontlsnpth)