aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/ChangeLog6
-rw-r--r--common/Makefile.am1
-rw-r--r--common/util.h3
3 files changed, 9 insertions, 1 deletions
diff --git a/common/ChangeLog b/common/ChangeLog
index f5c5c0982..a42b07b4d 100644
--- a/common/ChangeLog
+++ b/common/ChangeLog
@@ -1,3 +1,7 @@
+2005-04-07 Werner Koch <[email protected]>
+
+ * sexputil.c: New.
+
2005-04-11 Marcus Brinkmann <[email protected]>
* simple-pwquery.c (simple_pwquery): Use spwq_secure_free.
@@ -442,7 +446,7 @@
(atoi_1,atoi_2,atoi_4,xtoi_1,xtoi_2): New.
- Copyright 2001, 2002 Free Software Foundation, Inc.
+ Copyright 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
This file is free software; as a special exception the author gives
unlimited permission to copy and/or distribute it, with or without
diff --git a/common/Makefile.am b/common/Makefile.am
index ed7659793..a039be184 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -27,6 +27,7 @@ libcommon_a_SOURCES = \
util.h i18n.h \
errors.h \
sexp-parse.h \
+ sexputil.c \
maperror.c \
sysutils.c sysutils.h \
homedir.c \
diff --git a/common/util.h b/common/util.h
index bbf7241a3..14180bec4 100644
--- a/common/util.h
+++ b/common/util.h
@@ -120,6 +120,9 @@ gpg_error_t b64enc_write (struct b64state *state,
const void *buffer, size_t nbytes);
gpg_error_t b64enc_finish (struct b64state *state);
+/*-- sexputil.c */
+gpg_error_t keygrip_from_canon_sexp (const unsigned char *key, size_t keylen,
+ unsigned char *grip);
/*-- homedir. c --*/
const char *default_homedir (void);