aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--g10/ChangeLog3
-rw-r--r--g10/openfile.c3
2 files changed, 4 insertions, 2 deletions
diff --git a/g10/ChangeLog b/g10/ChangeLog
index 429ab368d..498d247b9 100644
--- a/g10/ChangeLog
+++ b/g10/ChangeLog
@@ -1,6 +1,7 @@
2004-08-31 Werner Koch <[email protected]>
- * openfile.c (copy_options_file): Use gpg-conf.skel
+ * openfile.c (copy_options_file): Use gpg-conf.skel. Better take
+ the length of SKELEXT into account, someone might make it larger.
* Makefile.am: Install options.skel as gpg-conf.skel.
2004-08-18 Marcus Brinkmann <[email protected]>
diff --git a/g10/openfile.c b/g10/openfile.c
index 663c2c5d3..dbf42db78 100644
--- a/g10/openfile.c
+++ b/g10/openfile.c
@@ -308,7 +308,8 @@ copy_options_file( const char *destdir )
if( opt.dry_run )
return;
- fname = xmalloc ( strlen(datadir) + strlen(destdir) + 15 );
+ fname = xmalloc ( strlen(datadir) + strlen(destdir)
+ strlen (SKELEXT) + 15 );
strcpy(stpcpy(fname, datadir), DIRSEP_S "gpg-conf" SKELEXT );
src = fopen( fname, "r" );
if( !src ) {