aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--cipher/ChangeLog5
-rw-r--r--cipher/Makefile.am11
-rw-r--r--cipher/md.c5
3 files changed, 13 insertions, 8 deletions
diff --git a/cipher/ChangeLog b/cipher/ChangeLog
index 7bda5084f..269d67d23 100644
--- a/cipher/ChangeLog
+++ b/cipher/ChangeLog
@@ -1,3 +1,8 @@
+2002-08-08 David Shaw <[email protected]>
+
+ * Makefile.am, md.c (load_digest_module): Allow switching TIGER on
+ and off via configure.
+
2002-08-07 David Shaw <[email protected]>
* md.c (md_algo_present): New function to check if a given algo is
diff --git a/cipher/Makefile.am b/cipher/Makefile.am
index 6f6ec3298..c73cccd7e 100644
--- a/cipher/Makefile.am
+++ b/cipher/Makefile.am
@@ -51,15 +51,12 @@ libcipher_a_SOURCES = cipher.c \
rndw32.c \
md5.c \
rmd160.c \
- sha1.c \
- tiger.c
+ sha1.c
-EXTRA_libcipher_a_SOURCES = idea-stub.c
+EXTRA_libcipher_a_SOURCES = idea-stub.c tiger.c
-libcipher_a_DEPENDENCIES = @IDEA_O@
-libcipher_a_LIBADD = @IDEA_O@
+libcipher_a_DEPENDENCIES = @IDEA_O@ @TIGER_O@
+libcipher_a_LIBADD = @IDEA_O@ @TIGER_O@
tiger.o: $(srcdir)/tiger.c
`echo $(COMPILE) -c $(srcdir)/tiger.c | sed -e 's/-O[2-9s]*/-O1/g' `
-
-
diff --git a/cipher/md.c b/cipher/md.c
index 73a2b33cf..34888b9a7 100644
--- a/cipher/md.c
+++ b/cipher/md.c
@@ -95,7 +95,10 @@ load_digest_module (void)
/* We load them in reverse order so that the most
frequently used are the first in the list. */
- new_list_item (DIGEST_ALGO_TIGER, tiger_get_info);
+#ifdef USE_TIGER
+ if (!new_list_item (DIGEST_ALGO_TIGER, tiger_get_info))
+ BUG();
+#endif
if (!new_list_item (DIGEST_ALGO_MD5, md5_get_info))
BUG ();
if (!new_list_item (DIGEST_ALGO_RMD160, rmd160_get_info))