aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/ChangeLog4
-rw-r--r--common/Makefile.am3
-rw-r--r--common/cryptmiss.c39
3 files changed, 45 insertions, 1 deletions
diff --git a/common/ChangeLog b/common/ChangeLog
index 8e5563f21..0522662bc 100644
--- a/common/ChangeLog
+++ b/common/ChangeLog
@@ -1,3 +1,7 @@
+2002-04-15 Werner Koch <[email protected]>
+
+ * cryptmiss.c: New.
+
2002-02-14 Werner Koch <[email protected]>
* maperror.c: Add more assuan<->gnupg mappings.
diff --git a/common/Makefile.am b/common/Makefile.am
index a95eadd7b..4c3fc8947 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -32,7 +32,8 @@ libcommon_a_SOURCES = \
errors.c errors.h \
maperror.c \
sysutils.c sysutils.h \
- no-pth.c
+ no-pth.c \
+ cryptmiss.c
libcommon_a_LIBADD = @LIBOBJS@
diff --git a/common/cryptmiss.c b/common/cryptmiss.c
new file mode 100644
index 000000000..ae639db1d
--- /dev/null
+++ b/common/cryptmiss.c
@@ -0,0 +1,39 @@
+/* cryptmiss.c - Missing functions in libgcrypt
+ * Copyright (C) 2002 Free Software Foundation, Inc.
+ *
+ * This file is part of GnuPG.
+ *
+ * GnuPG is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * GnuPG is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+ */
+
+#include <config.h>
+#include <errno.h>
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+#include <ctype.h>
+
+#include "util.h"
+
+char *
+gcry_strdup (const char *string)
+{
+ char *p;
+
+ p = gcry_malloc (strlen (string)+1);
+ if (p)
+ strcpy (p, string);
+ return p;
+}