aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--util/ChangeLog9
-rw-r--r--util/Makefile.am2
-rw-r--r--util/g10u.c40
-rw-r--r--util/iobuf.c1
4 files changed, 11 insertions, 41 deletions
diff --git a/util/ChangeLog b/util/ChangeLog
index b1ba66075..a22d2c38a 100644
--- a/util/ChangeLog
+++ b/util/ChangeLog
@@ -1,3 +1,12 @@
+2003-12-29 David Shaw <[email protected]>
+
+ * g10u.c: Dead code. Remove.
+
+ * Makefile.am: Don't compile g10u.c.
+
+ * iobuf.c (block_filter): Properly handle a partial body stream
+ that ends with a 5-byte length.
+
2003-12-28 David Shaw <[email protected]>
* http.c (send_request, http_open_document, http_open): Pass the
diff --git a/util/Makefile.am b/util/Makefile.am
index cca276eba..59896b1a4 100644
--- a/util/Makefile.am
+++ b/util/Makefile.am
@@ -25,7 +25,7 @@ noinst_LIBRARIES = libutil.a
EXTRA_libutil_a_SOURCES = regcomp.c regex.c regexec.c regex_internal.c regex_internal.h
#libutil_a_LDFLAGS =
-libutil_a_SOURCES = g10u.c logger.c fileutil.c miscutil.c strgutil.c \
+libutil_a_SOURCES = logger.c fileutil.c miscutil.c strgutil.c \
ttyio.c argparse.c memory.c secmem.c errors.c iobuf.c \
dotlock.c http.c srv.h srv.c simple-gettext.c w32reg.c
diff --git a/util/g10u.c b/util/g10u.c
deleted file mode 100644
index 2ce3a4e36..000000000
--- a/util/g10u.c
+++ /dev/null
@@ -1,40 +0,0 @@
-/* g10u.c - Wrapper for utility functions
- * Copyright (C) 1998 Free Software Foundation, Inc.
- *
- * This file is part of GnuPG.
- *
- * GnuPG is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2 of the License, or
- * (at your option) any later version.
- *
- * GnuPG is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
- */
-
-#include <config.h>
-#include <stdio.h>
-#include <stdlib.h>
-#include "mpi.h"
-#include "util.h"
-
-
-/* FIXME: The modules should use functions from libgcrypt */
-
-const char *g10u_revision_string(int dummy) { return "$Revision$"; }
-
-
-void *g10_malloc( size_t n ) { return m_alloc( n ); }
-void *g10_calloc( size_t n ) { return m_alloc_clear( n ); }
-void *g10_malloc_secure( size_t n ) { return m_alloc_secure( n ); }
-void *g10_calloc_secure( size_t n ) { return m_alloc_secure_clear( n ); }
-void *g10_realloc( void *a, size_t n ) { return m_realloc( a, n ); }
-void g10_free( void *p ) { m_free( p ); }
-char *g10_strdup( const char * a) { return m_strdup( a ); }
-
diff --git a/util/iobuf.c b/util/iobuf.c
index 5bef61bd0..3d55349b8 100644
--- a/util/iobuf.c
+++ b/util/iobuf.c
@@ -665,6 +665,7 @@ block_filter(void *opaque, int control, IOBUF chain, byte *buf, size_t *ret_len)
break;
}
a->size |= c;
+ a->partial = 2;
}
else { /* next partial body length */
a->size = 1 << (c & 0x1f);