aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ChangeLog4
-rw-r--r--NEWS10
-rw-r--r--THANKS1
-rw-r--r--common/ChangeLog4
-rw-r--r--common/http.c1
-rw-r--r--common/util.h3
-rw-r--r--configure.ac2
-rw-r--r--scd/ChangeLog7
-rw-r--r--scd/apdu.c4
-rw-r--r--sm/ChangeLog5
-rw-r--r--sm/certdump.c2
-rw-r--r--tools/ChangeLog4
-rw-r--r--tools/Makefile.am4
13 files changed, 40 insertions, 11 deletions
diff --git a/ChangeLog b/ChangeLog
index bb40b93ab..0829b3435 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2006-11-28 Werner Koch <[email protected]>
+
+ Released 2.0.1.
+
2006-11-23 Werner Koch <[email protected]>
Released 2.0.1rc1.
diff --git a/NEWS b/NEWS
index 57269aa82..786cb8b39 100644
--- a/NEWS
+++ b/NEWS
@@ -1,16 +1,18 @@
-Noteworthy changes in version 2.0.1 (not released)
--------------------------------------------------
+Noteworthy changes in version 2.0.1 (2006-11-28)
+------------------------------------------------
* Experimental support for the PIN pads of the SPR 532 and the Kaan
Advanced card readers. Add "disable-keypad" scdaemon.conf if you
don't want it. Does currently only work for the OpenPGP card and
- the authentication and decrypt keys.
+ its authentication and decrypt keys.
* Fixed build problems on some some platforms and crashes on amd64.
+ * Fixed a buffer overflow in gpg2. [bug#728]
+
Noteworthy changes in version 2.0.0 (2006-11-11)
--------------------------------------------------
+------------------------------------------------
* First stable version of a GnuPG integrating OpenPGP and S/MIME.
diff --git a/THANKS b/THANKS
index 868e75578..4e076e807 100644
--- a/THANKS
+++ b/THANKS
@@ -219,6 +219,7 @@ Steffen Ullrich ccrlphr at xensei.com
Steffen Zahn zahn at berlin.snafu.de
Steven Bakker steven at icoe.att.com
Steven Murdoch sjmurdoch at bigfoot.com
+Stoyan Angelov s_angelov at filibeto.org
Susanne Schultz schultz at hsp.de
Tavis Ormandy taviso at gentoo.org
Ted Cabeen secabeen at pobox.com
diff --git a/common/ChangeLog b/common/ChangeLog
index 63d856636..141838a9c 100644
--- a/common/ChangeLog
+++ b/common/ChangeLog
@@ -1,3 +1,7 @@
+2006-11-23 Werner Koch <[email protected]>
+
+ * http.c: Include i18n.h
+
2006-11-21 Werner Koch <[email protected]>
* estream.c: Remove explicit Pth soft mapping diabling becuase it
diff --git a/common/http.c b/common/http.c
index 3720b00af..6a015d1b3 100644
--- a/common/http.c
+++ b/common/http.c
@@ -70,6 +70,7 @@ typedef gnutls_transport_ptr gnutls_transport_ptr_t;
#endif
#include "util.h"
+#include "i18n.h"
#include "http.h"
#ifdef USE_DNS_SRV
#include "srv.h"
diff --git a/common/util.h b/common/util.h
index 11ff50503..f93283045 100644
--- a/common/util.h
+++ b/common/util.h
@@ -34,7 +34,7 @@
/* Hash function used with libksba. */
#define HASH_FNC ((void (*)(void *, const void*,size_t))gcry_md_write)
-/* get all the stuff from jnlib */
+/* Get all the stuff from jnlib. */
#include "../jnlib/logging.h"
#include "../jnlib/argparse.h"
#include "../jnlib/stringhelp.h"
@@ -43,6 +43,7 @@
#include "../jnlib/dotlock.h"
#include "../jnlib/utf8conv.h"
+
#if __GNUC__ >= 4
# define GNUPG_GCC_A_SENTINEL(a) __attribute__ ((sentinel(a)))
#else
diff --git a/configure.ac b/configure.ac
index c1d101bd4..81758b1b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,7 +26,7 @@ min_automake_version="1.9.3"
# Remember to change the version number immediately *after* a release.
# Set my_issvn to "yes" for non-released code. Remember to run an
# "svn up" and "autogen.sh" right before creating a distribution.
-m4_define([my_version], [2.0.1rc1])
+m4_define([my_version], [2.0.1])
m4_define([my_issvn], [no])
diff --git a/scd/ChangeLog b/scd/ChangeLog
index 3e65fc9eb..49896af94 100644
--- a/scd/ChangeLog
+++ b/scd/ChangeLog
@@ -1,3 +1,10 @@
+2006-11-28 Werner Koch <[email protected]>
+
+ * apdu.c (send_le, apdu_send_direct): Increase RESULTLEN to 258 to
+ allow for full 256 byte and the status word. This might break
+ some old PC/SC drivers or cards, but we will see. Suggested by
+ Kenneth Wang.
+
2006-11-23 Werner Koch <[email protected]>
* command.c (scd_command_handler): Fixed use of CTRL.
diff --git a/scd/apdu.c b/scd/apdu.c
index 3057d6415..ac2f3c44b 100644
--- a/scd/apdu.c
+++ b/scd/apdu.c
@@ -2603,7 +2603,7 @@ send_le (int slot, int class, int ins, int p0, int p1,
unsigned char **retbuf, size_t *retbuflen,
struct pininfo_s *pininfo)
{
-#define RESULTLEN 256
+#define RESULTLEN 258
unsigned char result[RESULTLEN+10]; /* 10 extra in case of bugs in
the driver. */
size_t resultlen;
@@ -2866,7 +2866,7 @@ apdu_send_direct (int slot, const unsigned char *apdudata, size_t apdudatalen,
int handle_more,
unsigned char **retbuf, size_t *retbuflen)
{
-#define RESULTLEN 256
+#define RESULTLEN 258
unsigned char apdu[5+256+1];
size_t apdulen;
unsigned char result[RESULTLEN+10]; /* 10 extra in case of bugs in
diff --git a/sm/ChangeLog b/sm/ChangeLog
index 2229a6869..a3c818a72 100644
--- a/sm/ChangeLog
+++ b/sm/ChangeLog
@@ -1,3 +1,8 @@
+2006-11-24 Werner Koch <[email protected]>
+
+ * certdump.c (parse_dn_part): Take '#' as a special character only
+ at the beginning of a string.
+
2006-11-21 Werner Koch <[email protected]>
* certdump.c (my_funopen_hook_ret_t): New.
diff --git a/sm/certdump.c b/sm/certdump.c
index 9f398d5ce..65c604e12 100644
--- a/sm/certdump.c
+++ b/sm/certdump.c
@@ -376,7 +376,7 @@ parse_dn_part (struct dn_array_s *array, const unsigned char *string)
else if (*s == '\"')
return NULL; /* invalid encoding */
else if (*s == ',' || *s == '=' || *s == '+'
- || *s == '<' || *s == '>' || *s == '#' || *s == ';' )
+ || *s == '<' || *s == '>' || *s == ';' )
break;
else
n++;
diff --git a/tools/ChangeLog b/tools/ChangeLog
index 1dc65c624..1e695711d 100644
--- a/tools/ChangeLog
+++ b/tools/ChangeLog
@@ -1,3 +1,7 @@
+2006-11-23 Werner Koch <[email protected]>
+
+ * Makefile.am (gpg_connect_agent_LDADD): Add NETLIBS.
+
2006-11-21 Werner Koch <[email protected]>
* gpgconf-comp.c (list_one_option): Cast print size_t arg.
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 9aa2c4e85..5e72f64cd 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -73,8 +73,8 @@ watchgnupg_SOURCES = watchgnupg.c
watchgnupg_LDADD = $(NETLIBS)
gpg_connect_agent_SOURCES = gpg-connect-agent.c no-libgcrypt.c
-gpg_connect_agent_LDADD = $(common_libs) \
- $(LIBASSUAN_LIBS) $(GPG_ERROR_LIBS) $(LIBINTL)
+gpg_connect_agent_LDADD = $(common_libs) $(LIBASSUAN_LIBS) \
+ $(GPG_ERROR_LIBS) $(LIBINTL) $(NETLIBS)
gpgkey2ssh_SOURCES = gpgkey2ssh.c
gpgkey2ssh_CFLAGS = $(LIBGCRYPT_CFLAGS) $(GPG_ERROR_CFLAGS)