aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--build-aux/speedo.mk28
-rw-r--r--build-aux/speedo/w32/inst.nsi8
2 files changed, 21 insertions, 15 deletions
diff --git a/build-aux/speedo.mk b/build-aux/speedo.mk
index a0e29a578..984c9e989 100644
--- a/build-aux/speedo.mk
+++ b/build-aux/speedo.mk
@@ -187,14 +187,19 @@ speedo_spkgs += \
endif
endif
+ifeq ($(TARGETOS),w32)
+speedo_spkgs += pinentry
ifeq ($(WITH_GUI),1)
-speedo_spkgs += \
- pinentry gpa
-ifeq ($(TARGETOS),w32)
-speedo_spkgs += \
- gpgex
+speedo_spkgs += gpa gpgex
endif
+
+else
+
+ifeq ($(WITH_GUI),1)
+speedo_spkgs += pinentry gpa
+endif
+
endif
@@ -437,14 +442,19 @@ speedo_pkg_gpgme_configure = \
LDFLAGS=-L$(idir)/lib
endif
-speedo_pkg_pinentry_configure = \
- --disable-pinentry-qt --disable-pinentry-qt4 --disable-pinentry-gtk \
- --enable-pinentry-gtk2 \
- --with-glib-prefix=$(idir) --with-gtk-prefix=$(idir) \
+
+ifeq ($(TARGETOS),w32)
+speedo_pkg_pinentry_configure = --disable-pinentry-gtk2
+else
+speedo_pkg_pinentry_configure = --enable-pinentry-gtk2
+endif
+speedo_pkg_pinentry_configure += \
+ --disable-pinentry-qt4 \
CPPFLAGS=-I$(idir)/include \
LDFLAGS=-L$(idir)/lib \
CXXFLAGS=-static-libstdc++
+
speedo_pkg_gpa_configure = \
--with-libiconv-prefix=$(idir) --with-libintl-prefix=$(idir) \
--with-gpgme-prefix=$(idir) --with-zlib=$(idir) \
diff --git a/build-aux/speedo/w32/inst.nsi b/build-aux/speedo/w32/inst.nsi
index e88a91c5c..19babb9eb 100644
--- a/build-aux/speedo/w32/inst.nsi
+++ b/build-aux/speedo/w32/inst.nsi
@@ -816,12 +816,10 @@ Section "-gtk+" SEC_gtk_
SectionEnd
!endif
-!ifdef WITH_GUI
Section "-pinentry" SEC_pinentry
SetOutPath "$INSTDIR\bin"
- File /oname=pinentry.exe "bin/pinentry-gtk-2.exe"
+ File /oname=pinentry-basic.exe "bin/pinentry-w32.exe"
SectionEnd
-!endif
!ifdef WITH_GUI
Section "gpa" SEC_gpa
@@ -933,11 +931,9 @@ Section "-un.gpa"
SectionEnd
!endif
-!ifdef WITH_GUI
Section "-un.pinentry"
- Delete "$INSTDIR\bin\pinentry.exe"
+ Delete "$INSTDIR\bin\pinentry-basic.exe"
SectionEnd
-!endif
!ifdef WITH_GUI
Section "-un.gtk+"