aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/ChangeLog7
-rw-r--r--common/Makefile.am1
-rw-r--r--common/miscellaneous.c19
-rw-r--r--common/xasprintf.c44
4 files changed, 52 insertions, 19 deletions
diff --git a/common/ChangeLog b/common/ChangeLog
index 8e5c615d9..1266a88c5 100644
--- a/common/ChangeLog
+++ b/common/ChangeLog
@@ -1,3 +1,10 @@
+2004-01-30 Marcus Brinkmann <[email protected]>
+
+ * Makefile.am (libcommon_a_SOURCES): Add xasprintf.c.
+ * miscellaneous.c (xasprintf): Moved to ...
+ * xasprintf (xasprintf): ... here. New file.
+ This allows to use xasprintf without sucking in gpg-error.
+
2004-01-27 Werner Koch <[email protected]>
* sexp-parse.h: New; moved from../agent.
diff --git a/common/Makefile.am b/common/Makefile.am
index 770ed12d6..640051be4 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -35,6 +35,7 @@ libcommon_a_SOURCES = \
gettime.c \
yesno.c \
miscellaneous.c \
+ xasprintf.c \
membuf.c membuf.h \
iobuf.c iobuf.h \
ttyio.c ttyio.h \
diff --git a/common/miscellaneous.c b/common/miscellaneous.c
index 4937bd7ce..86b0fcb3a 100644
--- a/common/miscellaneous.c
+++ b/common/miscellaneous.c
@@ -25,25 +25,6 @@
#include "util.h"
#include "iobuf.h"
-/* Same as asprintf but return an allocated buffer suitable to be
- freed using xfree. This function simply dies on memory failure,
- thus no extra check is required. */
-char *
-xasprintf (const char *fmt, ...)
-{
- va_list ap;
- char *buf, *p;
-
- va_start (ap, fmt);
- if (vasprintf (&buf, fmt, ap) < 0)
- log_fatal ("asprintf failed: %s\n", strerror (errno));
- va_end (ap);
- p = xstrdup (buf);
- free (buf);
- return p;
-}
-
-
/* Decide whether the filename is stdout or a real filename and return
* an appropriate string. */
diff --git a/common/xasprintf.c b/common/xasprintf.c
new file mode 100644
index 000000000..2c8fafc06
--- /dev/null
+++ b/common/xasprintf.c
@@ -0,0 +1,44 @@
+/* xasprintf.c
+ * Copyright (C) 2003 Free Software Foundation, Inc.
+ *
+ * This file is part of GnuPG.
+ *
+ * GnuPG is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * GnuPG is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+ */
+
+#include <config.h>
+#include <stdlib.h>
+#include <errno.h>
+
+#include "util.h"
+#include "iobuf.h"
+
+/* Same as asprintf but return an allocated buffer suitable to be
+ freed using xfree. This function simply dies on memory failure,
+ thus no extra check is required. */
+char *
+xasprintf (const char *fmt, ...)
+{
+ va_list ap;
+ char *buf, *p;
+
+ va_start (ap, fmt);
+ if (vasprintf (&buf, fmt, ap) < 0)
+ log_fatal ("asprintf failed: %s\n", strerror (errno));
+ va_end (ap);
+ p = xstrdup (buf);
+ free (buf);
+ return p;
+}