aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--tests/Makefile.am11
-rw-r--r--tests/samplekeys/distfiles4
2 files changed, 14 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 15c2e4cb7..ac0e6cb8c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -22,7 +22,7 @@
GPGSM = ../sm/gpgsm
# We can't unset a variable here so we unset GPG_AGENT_INFO in runtest
-TESTS_ENVIRONMENT = GNUPGHOME=`pwd` LC_ALL=C GPGSM=${GPGSM} ./runtest
+TESTS_ENVIRONMENT = GNUPGHOME=`pwd` LC_ALL=C GPGSM=$(GPGSM) $(srcdir)/runtest
EXTRA_DIST = runtest inittests \
text-1.txt text-2.txt text-3.txt \
@@ -50,6 +50,15 @@ inittests.stamp: inittests
$(TESTS_ENVIRONMENT) $(srcdir)/inittests
echo timestamp >./inittests.stamp
+# Include all files listed in the samplekeys/distfiles
+dist-hook:
+ @set -e; \
+ dir=$(srcdir)/samplekeys ; \
+ $(mkinstalldirs) $(distdir)/$$dir ; \
+ for i in distfiles `cat $$dir/distfiles` ; do \
+ ln $(srcdir)/$$dir/$$i $(distdir)/$$dir/$$i 2> /dev/null \
+ || cp -p $(srcdir)/$$dir/$$i $(distdir)/$$dir/$$i; \
+ done
diff --git a/tests/samplekeys/distfiles b/tests/samplekeys/distfiles
new file mode 100644
index 000000000..75f7fd181
--- /dev/null
+++ b/tests/samplekeys/distfiles
@@ -0,0 +1,4 @@
+32100C27173EF6E9C4E9A25D3D69F86D37A4F939.key
+cert_g10code_pete1.pem
+cert_g10code_test1.pem
+cert_g10code_theo1.pem