aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--agent/command-ssh.c4
-rw-r--r--configure.ac2
2 files changed, 3 insertions, 3 deletions
diff --git a/agent/command-ssh.c b/agent/command-ssh.c
index 9d45a1864..213f3f9f7 100644
--- a/agent/command-ssh.c
+++ b/agent/command-ssh.c
@@ -44,8 +44,8 @@
#include <sys/socket.h>
#include <sys/un.h>
#endif /*!HAVE_W32_SYSTEM*/
-#ifdef HAVE_UCRED_H
-#include <ucred.h>
+#ifdef HAVE_SYS_UCRED_H
+#include <sys/ucred.h>
#endif
#include "agent.h"
diff --git a/configure.ac b/configure.ac
index c3fce317d..424ce7be1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1278,7 +1278,7 @@ AC_HEADER_STDC
AC_CHECK_HEADERS([string.h unistd.h langinfo.h termio.h locale.h getopt.h \
pty.h utmp.h pwd.h inttypes.h signal.h sys/select.h \
stdint.h signal.h util.h libutil.h termios.h \
- ucred.h sys/sysmacros.h sys/mkdev.h])
+ sys/ucred.h sys/sysmacros.h sys/mkdev.h])
AC_HEADER_TIME