aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ChangeLog4
-rw-r--r--configure.ac2
-rw-r--r--tests/ChangeLog5
-rw-r--r--tests/Makefile.am8
4 files changed, 18 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index 73170cb53..210943c22 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2006-09-06 Marcus Brinkmann <[email protected]>
+
+ * configure.ac: New automake conditional RUN_GPG_TESTS.
+
2006-09-06 Werner Koch <[email protected]>
* configure.ac: Define _ASSUAN_ONLY_GPG_ERRORS. Require Assuan
diff --git a/configure.ac b/configure.ac
index afcc77dd9..bcce906e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1232,6 +1232,8 @@ AM_CONDITIONAL(BUILD_AGENT, test "$build_agent" = "yes")
AM_CONDITIONAL(BUILD_SCDAEMON, test "$build_scdaemon" = "yes")
AM_CONDITIONAL(BUILD_SYMCRYPTRUN, test "$build_symcryptrun" = "yes")
+AM_CONDITIONAL(RUN_GPG_TESTS,
+ test x$cross_compiling = xno -a "$build_gpg" = yes )
#
diff --git a/tests/ChangeLog b/tests/ChangeLog
index c7ce33dfe..e7e7c7f4b 100644
--- a/tests/ChangeLog
+++ b/tests/ChangeLog
@@ -1,3 +1,8 @@
+2006-09-06 Marcus Brinkmann <[email protected]>
+
+ * Makefile.am (openpgp): New variable.
+ (SUBDIRS): Conditionalize openpgp on RUN_GPG_TESTS.
+
2006-08-21 Werner Koch <[email protected]>
* Makefile.am (SUBDIRS): New.
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c4f7dd457..a3cfbbdda 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -29,7 +29,13 @@
#
#SUBDIRS = . ${pkits}
-SUBDIRS = openpgp
+if RUN_GPG_TESTS
+openpgp = openpgp
+else
+openpgp =
+endif
+
+SUBDIRS = ${openpgp}
GPGSM = ../sm/gpgsm