aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile.am2
-rw-r--r--README5
-rw-r--r--configure.ac14
-rw-r--r--tests/gpgscm/ffi.c8
-rw-r--r--tests/openpgp/all-tests.scm2
5 files changed, 28 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index e31d67ab5..b972cffa3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,7 +20,7 @@
ACLOCAL_AMFLAGS = -I m4
AM_DISTCHECK_CONFIGURE_FLAGS = --enable-gnupg-builddir-envvar \
- --enable-symcryptrun --enable-g13 \
+ --enable-all-tests --enable-symcryptrun --enable-g13 \
--enable-gpg2-is-gpg --enable-gpgtar --enable-wks-tools --disable-ntbtls
GITLOG_TO_CHANGELOG=gitlog-to-changelog
diff --git a/README b/README
index 9ade9fde7..a9a3eb04e 100644
--- a/README
+++ b/README
@@ -60,9 +60,12 @@
./configure
make
+ make check
make install
- (Before doing install you might need to become root.)
+ The "make check" is optional but highly recommended. To run even
+ more tests you may add "--enable-all-tests" to the configure run.
+ Before running the "make install" you might need to become root.
If everything succeeds, you have a working GnuPG with support for
OpenPGP, S/MIME, ssh-agent, and smartcards. Note that there is no
diff --git a/configure.ac b/configure.ac
index 20a6ed64e..3ff58655c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1668,6 +1668,20 @@ AC_ARG_ENABLE(optimization,
fi])
#
+# Configure option --enable-all-tests
+#
+AC_MSG_CHECKING([whether "make check" shall run all tests])
+AC_ARG_ENABLE(all-tests,
+ AC_HELP_STRING([--enable-all-tests],
+ [let "make check" run all tests]),
+ run_all_tests=$enableval, run_all_tests=no)
+AC_MSG_RESULT($run_all_tests)
+if test "$run_all_tests" = "yes"; then
+ AC_DEFINE(RUN_ALL_TESTS,1,
+ [Defined if "make check" shall run all tests])
+fi
+
+#
# We do not want support for the GNUPG_BUILDDIR environment variable
# in a released version. However, our regression tests suite requires
# this and thus we build with support for it during "make distcheck".
diff --git a/tests/gpgscm/ffi.c b/tests/gpgscm/ffi.c
index 4c2148a26..dde5b5282 100644
--- a/tests/gpgscm/ffi.c
+++ b/tests/gpgscm/ffi.c
@@ -1450,6 +1450,14 @@ ffi_init (scheme *sc, const char *argv0, const char *scriptname,
#endif
);
+ ffi_define (sc, "*run-all-tests*",
+#if RUN_ALL_TESTS
+ sc->T
+#else
+ sc->F
+#endif
+ );
+
ffi_define (sc, "*stdin*",
sc->vptr->mk_port_from_file (sc, stdin, port_input));
diff --git a/tests/openpgp/all-tests.scm b/tests/openpgp/all-tests.scm
index e65d52730..d687fe49b 100644
--- a/tests/openpgp/all-tests.scm
+++ b/tests/openpgp/all-tests.scm
@@ -58,7 +58,7 @@
(path-join "tests" "openpgp" name)
(in-srcdir "tests" "openpgp" name))) all-tests))
- (when *maintainer-mode*
+ (when *run-all-tests*
(set! tests
(append
tests