aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--cipher/ChangeLog6
-rw-r--r--cipher/Makefile.am10
-rw-r--r--cipher/md.c4
3 files changed, 14 insertions, 6 deletions
diff --git a/cipher/ChangeLog b/cipher/ChangeLog
index ded135287..314005540 100644
--- a/cipher/ChangeLog
+++ b/cipher/ChangeLog
@@ -1,3 +1,9 @@
+2003-02-11 David Shaw <[email protected]>
+
+ * Makefile.am, md.c (load_digest_module): Only build in SHA384/512
+ and TIGER if specifically enabled by the 64-bit type check in
+ configure.
+
2003-02-04 David Shaw <[email protected]>
* sha256.c, sha512.c: New.
diff --git a/cipher/Makefile.am b/cipher/Makefile.am
index 52adecc6a..0c87c51eb 100644
--- a/cipher/Makefile.am
+++ b/cipher/Makefile.am
@@ -52,14 +52,12 @@ libcipher_a_SOURCES = cipher.c \
md5.c \
rmd160.c \
sha1.c \
- sha256.c \
- sha512.c \
- tiger.c
+ sha256.c
-EXTRA_libcipher_a_SOURCES = idea-stub.c
+EXTRA_libcipher_a_SOURCES = idea-stub.c tiger.c sha512.c
-libcipher_a_DEPENDENCIES = @IDEA_O@
-libcipher_a_LIBADD = @IDEA_O@
+libcipher_a_DEPENDENCIES = @IDEA_O@ @TIGER_O@ @SHA512_O@
+libcipher_a_LIBADD = @IDEA_O@ @TIGER_O@ @SHA512_O@
tiger.o: $(srcdir)/tiger.c
`echo $(COMPILE) -c $(srcdir)/tiger.c | sed -e 's/-O[2-9s]*/-O1/g' `
diff --git a/cipher/md.c b/cipher/md.c
index c92390672..1b139568c 100644
--- a/cipher/md.c
+++ b/cipher/md.c
@@ -96,12 +96,16 @@ load_digest_module (void)
/* We load them in reverse order so that the most
frequently used are the first in the list. */
+#ifdef USE_TIGER
if (!new_list_item (DIGEST_ALGO_TIGER, tiger_get_info))
BUG();
+#endif
+#ifdef USE_SHA512
if (!new_list_item (DIGEST_ALGO_SHA512, sha512_get_info))
BUG ();
if (!new_list_item (DIGEST_ALGO_SHA384, sha384_get_info))
BUG ();
+#endif
if (!new_list_item (DIGEST_ALGO_SHA256, sha256_get_info))
BUG ();
if (!new_list_item (DIGEST_ALGO_MD5, md5_get_info))