aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--g10/ChangeLog11
-rw-r--r--g10/Makefile.am6
-rw-r--r--g10/apdu.c1
-rw-r--r--g10/gpg.c4
4 files changed, 18 insertions, 4 deletions
diff --git a/g10/ChangeLog b/g10/ChangeLog
index f9b189cd3..93da02b75 100644
--- a/g10/ChangeLog
+++ b/g10/ChangeLog
@@ -1,3 +1,14 @@
+2005-11-05 David Shaw <[email protected]>
+
+ * Makefile.am: Include @LIBUSB_CPPFLAGS@ in our CPPFLAGS.
+ Strictly speaking this should be only in gpg_CPPFLAGS, but then we
+ have to compile everything twice for gpg and gpgv.
+
+ * apdu.c (open_pcsc_reader): Fix double free.
+
+ * gpg.c (main) [__APPLE__]: Default the PCSC driver to the OS X
+ location. Suggested by Patty A. Hardy.
+
2005-11-02 David Shaw <[email protected]>
* trustdb.c (clean_sigs_from_uid): Include sigs from unavailable
diff --git a/g10/Makefile.am b/g10/Makefile.am
index 0fc40dd55..d6ca89f1b 100644
--- a/g10/Makefile.am
+++ b/g10/Makefile.am
@@ -19,14 +19,16 @@
## Process this file with automake to produce Makefile.in
-INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/intl
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/intl @LIBUSB_CPPFLAGS@
+
EXTRA_DIST = options.skel
# it seems that we can't use this with automake 1.5
#OMIT_DEPENDENCIES = zlib.h zconf.h
if ! HAVE_DOSISH_SYSTEM
-AM_CFLAGS = -DGNUPG_LIBEXECDIR="\"$(libexecdir)/@PACKAGE@\""
+AM_CPPFLAGS += -DGNUPG_LIBEXECDIR="\"$(libexecdir)/@PACKAGE@\""
endif
+
needed_libs = ../cipher/libcipher.a ../mpi/libmpi.a ../util/libutil.a
other_libs = $(LIBICONV) $(SRVLIBS) $(LIBINTL) $(CAPLIBS)
diff --git a/g10/apdu.c b/g10/apdu.c
index f59d832d4..5f8c57922 100644
--- a/g10/apdu.c
+++ b/g10/apdu.c
@@ -1603,7 +1603,6 @@ open_pcsc_reader (const char *portstr)
xfree (reader_table[slot].rdrname);
reader_table[slot].rdrname = NULL;
reader_table[slot].used = 0;
- xfree (list);
return -1 /*pcsc_error_to_sw (err)*/;
}
diff --git a/g10/gpg.c b/g10/gpg.c
index d0575c190..6c0efd0c8 100644
--- a/g10/gpg.c
+++ b/g10/gpg.c
@@ -1711,7 +1711,9 @@ main (int argc, char **argv )
#ifdef ENABLE_CARD_SUPPORT
#if defined(_WIN32) || defined(__CYGWIN__)
- opt.pcsc_driver = "winscard.dll";
+ opt.pcsc_driver = "winscard.dll";
+#elif defined(__APPLE__)
+ opt.pcsc_driver = "/System/Library/Frameworks/PCSC.framework/PCSC";
#else
opt.pcsc_driver = "libpcsclite.so";
#endif