aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac1
-rw-r--r--m4/readline.m43
2 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4b12f01df..c20984afd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1870,6 +1870,7 @@ echo "
Use standard socket: $use_standard_socket
Dirmngr auto start: $dirmngr_auto_start
+ Readline support: $gnupg_cv_have_readline
"
if test x"$use_regex" != xyes ; then
echo "
diff --git a/m4/readline.m4 b/m4/readline.m4
index 783f40123..0c9619dea 100644
--- a/m4/readline.m4
+++ b/m4/readline.m4
@@ -10,6 +10,7 @@ dnl
dnl Defines HAVE_LIBREADLINE to 1 if a working readline setup is
dnl found, and sets @LIBREADLINE@ to the necessary libraries.
+
AC_DEFUN([GNUPG_CHECK_READLINE],
[
AC_ARG_WITH(readline,
@@ -17,6 +18,7 @@ AC_DEFUN([GNUPG_CHECK_READLINE],
[look for the readline library in DIR]),
[_do_readline=$withval],[_do_readline=yes])
+ gnupg_cv_have_readline=no
if test "$_do_readline" != "no" ; then
if test -d "$withval" ; then
CPPFLAGS="${CPPFLAGS} -I$withval/include"
@@ -51,6 +53,7 @@ rl_completion_matches(NULL,NULL);
AC_DEFINE(HAVE_LIBREADLINE,1,
[Define to 1 if you have a fully functional readline library.])
AC_SUBST(LIBREADLINE,$_combo)
+ gnupg_cv_have_readline=yes
break
fi
done