aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--cipher/ChangeLog5
-rw-r--r--cipher/tiger.c9
2 files changed, 14 insertions, 0 deletions
diff --git a/cipher/ChangeLog b/cipher/ChangeLog
index 26b09cef9..80ac38ade 100644
--- a/cipher/ChangeLog
+++ b/cipher/ChangeLog
@@ -1,3 +1,8 @@
+2002-10-02 David Shaw <[email protected]>
+
+ * tiger.c (tiger_get_info): Select the OID to use for TIGER at
+ compile time.
+
2002-09-27 David Shaw <[email protected]>
* Makefile.am, md.c (load_digest_module): TIGER is now always
diff --git a/cipher/tiger.c b/cipher/tiger.c
index 95c8dbad7..1bb3375ed 100644
--- a/cipher/tiger.c
+++ b/cipher/tiger.c
@@ -897,10 +897,19 @@ tiger_get_info( int algo, size_t *contextsize,
)
{
#ifdef HAVE_U64_TYPEDEF
+
+#ifdef USE_OLD_TIGER
+ /* This is the old fake OID */
+ static byte asn[18] =
+ { 0x30, 0x28, 0x30, 0x0c, 0x04, 0x08, 0x54, 0x49, 0x47,
+ 0x45, 0x52, 0x31, 0x39, 0x32, 0x05, 0x00, 0x04, 0x18 };
+#else /* !USE_OLD_TIGER */
+ /* This is the new correct OID */
static byte asn[19] = /* Object ID is 1.3.6.1.4.1.11591.12.2 */
{ 0x30, 0x29, 0x30, 0x0d, 0x06, 0x09, 0x2b, 0x06,
0x01, 0x04, 0x01, 0xda, 0x47, 0x0c, 0x02,
0x05, 0x00, 0x04, 0x18 };
+#endif
if( algo != 6 )
return NULL;