aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--ChangeLog5
-rw-r--r--configure.ac2
2 files changed, 6 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index 1ada7a643..5cf8b3c07 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+2003-03-04 David Shaw <[email protected]>
+
+ * configure.ac: Define @CAPLIBS@ to link in -lcap if we are using
+ capabilities.
+
2003-02-22 David Shaw <[email protected]>
* configure.ac: Add --disable-idea for IDEA. Note that disabling
diff --git a/configure.ac b/configure.ac
index 3ca85b2af..888db1eee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -738,7 +738,7 @@ if test "$ac_cv_header_sys_capability_h" = "yes" ; then
if test "$ac_cv_lib_cap_cap_init" = "yes"; then
AC_DEFINE(USE_CAPABILITIES,1,
[define if capabilities should be used])
- LIBS="$LIBS -lcap"
+ AC_SUBST(CAPLIBS,"-lcap")
use_capabilities=yes
fi
fi