aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--g10/ChangeLog5
-rw-r--r--g10/Makefile.am2
-rw-r--r--g10/ccid-driver.c3
3 files changed, 9 insertions, 1 deletions
diff --git a/g10/ChangeLog b/g10/ChangeLog
index b2f0c2629..7d23d53e4 100644
--- a/g10/ChangeLog
+++ b/g10/ChangeLog
@@ -1,5 +1,10 @@
2003-10-25 Werner Koch <[email protected]>
+ * ccid-driver.c (ccid_open_reader): Return an error if no USB
+ devices are found.
+
+ * Makefile.am: Replaced INTLLIBS by LIBINTL.
+
* g10.c (main) [ENABLE_CARD_SUPPORT]: Add a default for
--pcsc-driver.
diff --git a/g10/Makefile.am b/g10/Makefile.am
index 730039e77..37fbe0079 100644
--- a/g10/Makefile.am
+++ b/g10/Makefile.am
@@ -124,7 +124,7 @@ gpgv_SOURCES = gpgv.c \
# ks-db.h \
# $(common_source)
-LDADD = $(needed_libs) @INTLLIBS@ @CAPLIBS@ @ZLIBS@ @W32LIBS@
+LDADD = $(needed_libs) @LIBINTL@ @CAPLIBS@ @ZLIBS@ @W32LIBS@
# gpg gets LIBOBJS to add in mkdtemp if the platform doesn't have it
gpg_LDADD = @LIBOBJS@ $(LDADD) @DLLIBS@ @NETLIBS@ @LIBUSB_LIBS@
diff --git a/g10/ccid-driver.c b/g10/ccid-driver.c
index 8868a2cfc..099dae240 100644
--- a/g10/ccid-driver.c
+++ b/g10/ccid-driver.c
@@ -494,6 +494,9 @@ ccid_open_reader (ccid_driver_t *handle, int readerno)
shallow copy of the list created internally by usb_init ? */
usb_free_match (match);
+ if (!rc && !*handle)
+ rc = -1; /* In case we didn't enter the while lool at all. */
+
return rc;
}