aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac3
-rw-r--r--tools/symcryptrun.c12
2 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bec7428f8..5fc2b8518 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1274,7 +1274,8 @@ AC_MSG_NOTICE([checking for header files])
AC_HEADER_STDC
AC_CHECK_HEADERS([string.h unistd.h langinfo.h termio.h locale.h getopt.h \
pty.h utmp.h pwd.h inttypes.h signal.h sys/select.h \
- stdint.h signal.h])
+ stdint.h signal.h util.h libutil.h termios.h])
+
AC_HEADER_TIME
diff --git a/tools/symcryptrun.c b/tools/symcryptrun.c
index a72b9cf7a..b32d43ac8 100644
--- a/tools/symcryptrun.c
+++ b/tools/symcryptrun.c
@@ -71,9 +71,21 @@
#include <sys/stat.h>
#include <sys/types.h>
#include <sys/wait.h>
+
#ifdef HAVE_PTY_H
#include <pty.h>
+#else
+#ifdef HAVE_TERMIOS_H
+#include <termios.h>
+#endif
+#ifdef HAVE_UTIL_H
+#include <util.h>
+#endif
+#ifdef HAVE_LIBUTIL_H
+#include <libutil.h>
#endif
+#endif
+
#ifdef HAVE_UTMP_H
#include <utmp.h>
#endif