aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--doc/ChangeLog8
-rw-r--r--doc/DETAILS4
-rw-r--r--doc/gpg-agent.texi10
-rw-r--r--doc/qualified.txt6
-rw-r--r--g10/ChangeLog4
-rw-r--r--g10/tdbio.c17
6 files changed, 35 insertions, 14 deletions
diff --git a/doc/ChangeLog b/doc/ChangeLog
index 476b5865d..b8de5f070 100644
--- a/doc/ChangeLog
+++ b/doc/ChangeLog
@@ -1,3 +1,9 @@
+2008-01-29 Justin Pryzby <[email protected]> (wk)
+
+ * gpg-agent.texi (Agent Options): Grammar fixes
+
+ * qualified.txt: Spelling fixes.
+
2008-01-28 Justin Pryzby <[email protected]> (wk)
* gpg-agent.texi, yat2m.c, scdaemon.texi, qualified.txt
@@ -559,7 +565,7 @@
* Makefile.am, gpgsm.texi: New.
- Copyright 2002, 2004, 2005 Free Software Foundation, Inc.
+ Copyright 2002, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
This file is free software; as a special exception the author gives
unlimited permission to copy and/or distribute it, with or without
diff --git a/doc/DETAILS b/doc/DETAILS
index 1582f6936..5c6d4602e 100644
--- a/doc/DETAILS
+++ b/doc/DETAILS
@@ -319,8 +319,8 @@ more arguments in future versions.
indicate how trustworthy the signature is. The error token
values are currently only emitted by gpgsm. VALIDATION_MODEL
describes the algorithm used to check the validity of the key.
- The default is the standard gpg Web of Trust model respective
- the standard X.509 model. The defined values are
+ The defaults are the standard Web of Trust model for gpg and the
+ the standard X.509 model for gpgsm. The defined values are
"pgp" for the standard PGP WoT.
"shell" for the standard X.509 model.
diff --git a/doc/gpg-agent.texi b/doc/gpg-agent.texi
index 6c3970117..aa5d14187 100644
--- a/doc/gpg-agent.texi
+++ b/doc/gpg-agent.texi
@@ -268,9 +268,9 @@ debugging.
@opindex c
@opindex csh
Format the info output in daemon mode for use with the standard Bourne
-shell respective the C-shell. The default is to guess it based on the
-environment variable @code{SHELL} which is in almost all cases
-correct.
+shell or the C-shell respectively. The default is to guess it based on
+the environment variable @code{SHELL} which is correct in almost all
+cases.
@item --write-env-file @var{file}
@opindex write-env-file
@@ -436,8 +436,8 @@ information.
@itemx --keep-display
@opindex keep-tty
@opindex keep-display
-Ignore requests to change the current @code{tty} respective the X
-window system's @code{DISPLAY} variable. This is useful to lock the
+Ignore requests to change the current @code{tty} or X window system's
+@code{DISPLAY} variable respectively. This is useful to lock the
pinentry to pop up at the @code{tty} or display you started the agent.
@anchor{option --enable-ssh-support}
diff --git a/doc/qualified.txt b/doc/qualified.txt
index a627cb069..7f8eab9d9 100644
--- a/doc/qualified.txt
+++ b/doc/qualified.txt
@@ -4,9 +4,9 @@
# signatures are. Comments like this one and empty lines are allowed
# Lines do have a length limit but this is not a serious limitation as
# the format of the entries is fixed and checked by gpgsm: A
-# non-comment line starts with optional white spaces, followed by
-# exactly 40 hex character, white space and a lowercased 2 letter
-# country code. Additional data delimited with by a white space is
+# non-comment line starts with optional whitespaces, followed by
+# exactly 40 hex character, whitespace and a lowercased 2 letter
+# country code. Additional data delimited with by a whitespace is
# current ignored but might late be used for other purposes.
#
# Note: The subversion copy of this file carries a gpg:signature
diff --git a/g10/ChangeLog b/g10/ChangeLog
index 1de64dcc5..3c52fea7e 100644
--- a/g10/ChangeLog
+++ b/g10/ChangeLog
@@ -1,3 +1,7 @@
+2008-01-30 Werner Koch <[email protected]>
+
+ * tdbio.c (tdbio_set_dbname): Also test for forward slash.
+
2008-01-29 Werner Koch <[email protected]>
* keydb.c (maybe_create_keyring): Take care of a missing slash.
diff --git a/g10/tdbio.c b/g10/tdbio.c
index d763d2a92..2429f1a5d 100644
--- a/g10/tdbio.c
+++ b/g10/tdbio.c
@@ -505,14 +505,25 @@ tdbio_set_dbname( const char *new_dbname, int create )
int rc;
char *p = strrchr( fname, DIRSEP_C );
mode_t oldmask;
-
- assert(p);
+ int save_slash;
+
+#if HAVE_W32_SYSTEM
+ {
+ /* Windows may either have a slash or a backslash. Take
+ care of it. */
+ char *pp = strrchr (fname, '/');
+ if (!p || pp > p)
+ p = pp;
+ }
+#endif /*HAVE_W32_SYSTEM*/
+ assert (p);
+ save_slash = *p;
*p = 0;
if( access( fname, F_OK ) ) {
try_make_homedir( fname );
log_fatal( _("%s: directory does not exist!\n"), fname );
}
- *p = DIRSEP_C;
+ *p = save_slash;
xfree(db_name);
db_name = fname;