aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--ChangeLog4
-rw-r--r--configure.ac8
2 files changed, 11 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index 0fb4257c2..dda3ccd51 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2003-10-23 Werner Koch <[email protected]>
+
+ * configure.ac (DLLIBS): Do not include -ldl in the mingw32 case.
+
2003-10-21 Werner Koch <[email protected]>
* configure.ac (PRINTABLE_OS_NAME): Remove special case for The
diff --git a/configure.ac b/configure.ac
index 7050f4dfc..9b915578f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -634,7 +634,13 @@ if test "$try_extensions" = yes || test x"$card_support" = xyes ; then
if test x"$found_dlopen" = "xyes" ; then
AC_DEFINE(HAVE_DL_DLOPEN,1,
[Defined when the dlopen function family is available])
- AC_SUBST(DLLIBS,"-ldl")
+ case "${target}" in
+ *-*-mingw32*)
+ ;;
+ *)
+ AC_SUBST(DLLIBS,"-ldl")
+ ;;
+ esac
if test "$try_extensions" = yes ; then
AC_DEFINE(USE_DYNAMIC_LINKING,1,