diff options
Diffstat (limited to '')
-rw-r--r-- | ChangeLog | 5 | ||||
-rw-r--r-- | configure.ac | 11 |
2 files changed, 16 insertions, 0 deletions
@@ -1,3 +1,8 @@ +2002-07-03 David Shaw <[email protected]> + + * configure.ac: Allow setting USE_EXEC_PATH to lock the exec-path + to a fixed value. + 2002-07-01 Werner Koch <[email protected]> * configure.ac: Set version number to 1.1.91. diff --git a/configure.ac b/configure.ac index da1e345cd..65bc08726 100644 --- a/configure.ac +++ b/configure.ac @@ -130,6 +130,17 @@ if test "$use_exec" = no ; then fi if test "$use_exec" = yes ; then + AC_MSG_CHECKING([for a restricted exec-path]) + AC_ARG_WITH(exec-path, + [ --with-exec-path=PATH restrict exec-path to PATH], + [if test "$withval" = yes ; then + withval=no + else + AC_DEFINE_UNQUOTED(USE_EXEC_PATH,"$withval", + [restrict exec-path to this]) + fi],withval=no) + AC_MSG_RESULT($withval) + AC_MSG_CHECKING([whether LDAP keyserver support is requested]) AC_ARG_ENABLE(ldap, [ --disable-ldap disable LDAP keyserver interface], |