aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--common/Makefile.am8
-rw-r--r--common/t-http.c2
2 files changed, 9 insertions, 1 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 40fdabd17..03bc5eb06 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -181,13 +181,21 @@ module_tests = t-convert t-percent t-gettime t-sysutils t-sexputil \
if !HAVE_W32CE_SYSTEM
module_tests += t-exechelp
endif
+
+if MAINTAINER_MODE
module_maint_tests = t-helpfile t-b64 t-http
+else
+module_maint_tests =
+endif
+t_common_cflags = $(KSBA_CFLAGS) $(LIBGCRYPT_CFLAGS) \
+ $(LIBASSUAN_CFLAGS) $(GPG_ERROR_CFLAGS)
t_common_ldadd = libcommon.a ../gl/libgnu.a \
$(LIBGCRYPT_LIBS) $(LIBASSUAN_LIBS) $(GPG_ERROR_LIBS) \
$(LIBINTL) $(LIBICONV)
+
# jnlib tests
t_stringhelp_SOURCES = t-stringhelp.c $(t_jnlib_src)
t_stringhelp_LDADD = $(t_common_ldadd)
diff --git a/common/t-http.c b/common/t-http.c
index d4c974dc1..9872f9a74 100644
--- a/common/t-http.c
+++ b/common/t-http.c
@@ -226,7 +226,7 @@ main (int argc, char **argv)
}
if (argc != 1)
{
- fprintf (stderr, PGM ": no or roo many URLS given\n");
+ fprintf (stderr, PGM ": no or too many URLS given\n");
exit (1);
}