aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--NEWS2
-rw-r--r--cipher/ChangeLog5
-rw-r--r--cipher/rndunix.c9
-rw-r--r--keyserver/ChangeLog5
-rw-r--r--keyserver/gpgkeys_finger.c2
-rw-r--r--m4/Makefile.in1
6 files changed, 21 insertions, 3 deletions
diff --git a/NEWS b/NEWS
index 13e8ef0c6..d2de125f2 100644
--- a/NEWS
+++ b/NEWS
@@ -3,7 +3,7 @@ Noteworthy changes in version 1.3.91
* A new configure option --enable-selinux-support disallows
processing of confidential files used by gpg (e.g. secring.gpg).
- This help designing ACLs for the SELinux kernel.
+ This helps writing ACLs for the SELinux kernel.
Noteworthy changes in version 1.3.90 (2004-10-01)
diff --git a/cipher/ChangeLog b/cipher/ChangeLog
index 75c143ff3..ef01c1dd4 100644
--- a/cipher/ChangeLog
+++ b/cipher/ChangeLog
@@ -1,3 +1,8 @@
+2004-10-14 Werner Koch <[email protected]>
+
+ * rndunix.c (start_gatherer) [ENABLE_SELINUX_HACKS]: Don't allow
+ logging.
+
2004-10-12 David Shaw <[email protected]>
* algorithms.h, cast5.c, cipher.c, idea-stub.c, twofish.c,
diff --git a/cipher/rndunix.c b/cipher/rndunix.c
index a07fde325..c3b5cf8e2 100644
--- a/cipher/rndunix.c
+++ b/cipher/rndunix.c
@@ -652,6 +652,13 @@ start_gatherer( int pipefd )
FILE *dbgfp = NULL;
int dbgall;
+#ifdef ENABLE_SELINUX_HACKS
+ /* We don't allow writing to the log file because this might be
+ sued to corrupt a secured file. Given that this is used as a
+ library by the ../g10/ code, we can't access the check function
+ from ../g10/misc.c. */
+ dbgall = 0;
+#else
{
const char *s = getenv("GNUPG_RNDUNIX_DBG");
if( s ) {
@@ -664,7 +671,7 @@ start_gatherer( int pipefd )
}
dbgall = !!getenv("GNUPG_RNDUNIX_DBGALL");
}
-
+#endif
/* Set up the buffer */
gather_buffer_size = GATHER_BUFSIZE;
diff --git a/keyserver/ChangeLog b/keyserver/ChangeLog
index da06d280e..ba05ef13b 100644
--- a/keyserver/ChangeLog
+++ b/keyserver/ChangeLog
@@ -1,3 +1,8 @@
+2004-10-14 Werner Koch <[email protected]>
+
+ * gpgkeys_finger.c (get_key): s/unsigned char/byte/ due
+ to a strange typedef for RISC OS. Noted by Stefan.
+
2004-10-13 David Shaw <[email protected]>
* gpgkeys_ldap.c (main), gpgkeys_hkp.c (main), gpgkeys_http.c
diff --git a/keyserver/gpgkeys_finger.c b/keyserver/gpgkeys_finger.c
index 43158cf90..31d139d6b 100644
--- a/keyserver/gpgkeys_finger.c
+++ b/keyserver/gpgkeys_finger.c
@@ -297,7 +297,7 @@ get_key (char *getkey)
int sock;
IOBUF fp_read;
unsigned int maxlen, buflen, gotit=0;
- unsigned char *line = NULL;
+ byte *line = NULL;
if (strncmp (getkey,"0x",2)==0)
getkey+=2;
diff --git a/m4/Makefile.in b/m4/Makefile.in
index de92c33f1..ad847e29b 100644
--- a/m4/Makefile.in
+++ b/m4/Makefile.in
@@ -79,6 +79,7 @@ GENCAT = @GENCAT@
GETOPT = @GETOPT@
GLIBC21 = @GLIBC21@
GMSGFMT = @GMSGFMT@
+GPGKEYS_FINGER = @GPGKEYS_FINGER@
GPGKEYS_HKP = @GPGKEYS_HKP@
GPGKEYS_HTTP = @GPGKEYS_HTTP@
GPGKEYS_LDAP = @GPGKEYS_LDAP@