aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--scripts/ChangeLog5
-rwxr-xr-xscripts/autogen.sh5
2 files changed, 10 insertions, 0 deletions
diff --git a/scripts/ChangeLog b/scripts/ChangeLog
index 05857e3cd..ec666cb03 100644
--- a/scripts/ChangeLog
+++ b/scripts/ChangeLog
@@ -1,3 +1,8 @@
+2003-08-28 David Shaw <[email protected]>
+
+ * autogen.sh: Touch po/all for --build-w32. From Werner on stable
+ branch.
+
2003-08-25 David Shaw <[email protected]>
* gnupg.spec.in: Rework much of the spec to use %-macros
diff --git a/scripts/autogen.sh b/scripts/autogen.sh
index b769355da..8b328e17d 100755
--- a/scripts/autogen.sh
+++ b/scripts/autogen.sh
@@ -72,6 +72,11 @@ if test "$1" = "--build-w32"; then
$tsdir/configure --build=${build} --host=${host} \
${disable_foo_tests} $*
+
+ # Ugly hack to overcome a gettext problem. Someone should look into
+ # gettext to figure out why the po directory is not ignored as it used
+ # to be.
+ [ $? = 0 ] && touch $tsdir/po/all
exit $?
fi