aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--ChangeLog7
-rw-r--r--NEWS9
-rw-r--r--configure.ac16
3 files changed, 25 insertions, 7 deletions
diff --git a/ChangeLog b/ChangeLog
index 36ec6037a..93bfaf20a 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,10 @@
+2005-02-11 David Shaw <[email protected]>
+
+ * configure.ac: Add --enable-fake-curl option to help test no-curl
+ HTTP.
+
+ * NEWS: Note Mister/Zuccherato CFB countermeasures.
+
2005-02-04 Werner Koch <[email protected]>
* configure.ac (GNUPG_CHECK_GNUMAKE): Removed. Not needed for
diff --git a/NEWS b/NEWS
index 56373dd44..c8cea2de9 100644
--- a/NEWS
+++ b/NEWS
@@ -5,7 +5,7 @@ Noteworthy changes in version 1.4.1
signatures. This is in response to some problems seen with
certain PGP/MIME mail clients and GnuPG version 1.4.0. More
details about this are available at
- <http://lists.gnupg.org/pipermail/gnupg-users/2005-January/024408.html>
+ <http://lists.gnupg.org/pipermail/gnupg-users/2005-January/024408.html>.
* New "import-unusable-sigs" and "export-unusable-sigs" tags for
--import-options and --export-options. These are off by
@@ -23,9 +23,12 @@ Noteworthy changes in version 1.4.1
available, missing secret key stubs will be created on the fly.
Details of the key are listed too.
- * The implicit packet dumping in double verbose mode is now send
+ * The implicit packet dumping in double verbose mode is now sent
to stderr and not to stdout.
+ * Added countermeasures against the Mister/Zuccherato CFB attack
+ <http://eprint.iacr.org/2005/033>.
+
* [W32] The algorithm for the default home directory changed:
First we look at the environment variable GNUPGHOME, if this one
is not set, we check whether the registry entry
@@ -38,7 +41,7 @@ Noteworthy changes in version 1.4.1
* [W32] The locale selection under Windows changed. You need to
enter the locale in the registry at HKCU\Software\GNU\GnuPG:Lang.
- For German you would use "de". If it is not set, GnupG falls
+ For German you would use "de". If it is not set, GnuPG falls
back to HKLM. The languages files "*.mo" are expected in a
directory named "gnupg.nls" below the installation directory;
that directory must be stored in the registry at the same key as
diff --git a/configure.ac b/configure.ac
index 12da089c8..8131799b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -645,11 +645,19 @@ AC_SUBST(GPGKEYS_LDAP)
AC_SUBST(LDAPLIBS)
AM_CONDITIONAL(GPGKEYS_LDAP, test "$GPGKEYS_LDAP" != "")
-# If we have neither FTP or HTTP defined, then don't bother to check
-# for curl.
+AC_ARG_ENABLE(fake-curl,
+ AC_HELP_STRING([--enable-fake-curl],[enable EXPERIMENTAL no-curl HTTP code]),fake_curl=$enableval,fake_curl=no)
-if test "$try_ftp" = yes || test "$try_http" = yes ; then
- LIBCURL_CHECK_CONFIG([no],,[have_libcurl=yes])
+AM_CONDITIONAL(FAKE_CURL,test x"$fake_curl" = xyes)
+
+if test x"$fake_curl" = xyes ; then
+ libcurl_protocol_HTTP=yes
+else
+ # If we have neither FTP or HTTP defined, then don't bother to check
+ # for curl.
+ if test x"$try_ftp" = xyes || test x"$try_http" = xyes ; then
+ LIBCURL_CHECK_CONFIG([no])
+ fi
fi
# Are we doing HTTP?