aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--g10/ChangeLog3
-rw-r--r--g10/Makefile.am1
-rw-r--r--g10/comment.c103
-rw-r--r--g10/main.h4
-rw-r--r--g10/packet.h3
5 files changed, 3 insertions, 111 deletions
diff --git a/g10/ChangeLog b/g10/ChangeLog
index efdedcc9e..d7697af2f 100644
--- a/g10/ChangeLog
+++ b/g10/ChangeLog
@@ -1,5 +1,8 @@
2005-05-05 David Shaw <[email protected]>
+ * Makefile.am, packet.h, main.h, comment.c: Remove comment.c. We
+ don't use any of these functions any longer.
+
* keygen.c (start_tree): New function to "prime" a KBNODE list.
(do_generate_keypair): Use it here rather than creating and
deleting a comment packet.
diff --git a/g10/Makefile.am b/g10/Makefile.am
index 2c8bc9a0f..160d7b4cd 100644
--- a/g10/Makefile.am
+++ b/g10/Makefile.am
@@ -62,7 +62,6 @@ common_source = \
keyid.c \
packet.h \
parse-packet.c \
- comment.c \
status.c \
status.h \
plaintext.c \
diff --git a/g10/comment.c b/g10/comment.c
deleted file mode 100644
index 6d27e481b..000000000
--- a/g10/comment.c
+++ /dev/null
@@ -1,103 +0,0 @@
-/* comment.c - write comment stuff
- * Copyright (C) 1998 Free Software Foundation, Inc.
- *
- * This file is part of GnuPG.
- *
- * GnuPG is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2 of the License, or
- * (at your option) any later version.
- *
- * GnuPG is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
- */
-
-#include <config.h>
-#include <stdio.h>
-#include <stdlib.h>
-#include <string.h>
-#include <errno.h>
-#include <assert.h>
-
-#include "options.h"
-#include "packet.h"
-#include "errors.h"
-#include "iobuf.h"
-#include "memory.h"
-#include "util.h"
-#include "main.h"
-#include "keydb.h"
-
-
-
-int
-write_comment( IOBUF out, const char *s )
-{
- PACKET pkt;
- size_t n = strlen(s);
- int rc=0;
-
- pkt.pkttype = PKT_COMMENT;
- if( *s != '#' ) {
- pkt.pkt.comment = m_alloc( sizeof *pkt.pkt.comment + n );
- pkt.pkt.comment->len = n+1;
- *pkt.pkt.comment->data = '#';
- strcpy(pkt.pkt.comment->data+1, s);
- }
- else {
- pkt.pkt.comment = m_alloc( sizeof *pkt.pkt.comment + n - 1 );
- pkt.pkt.comment->len = n;
- strcpy(pkt.pkt.comment->data, s);
- }
- if( (rc = build_packet( out, &pkt )) )
- log_error("build_packet(comment) failed: %s\n", g10_errstr(rc) );
- free_packet( &pkt );
- return rc;
-}
-
-
-KBNODE
-make_comment_node( const char *s )
-{
- PACKET *pkt;
- size_t n = strlen(s);
-
- pkt = m_alloc_clear( sizeof *pkt );
- pkt->pkttype = PKT_COMMENT;
- pkt->pkt.comment = m_alloc( sizeof *pkt->pkt.comment + n - 1 );
- pkt->pkt.comment->len = n;
- strcpy(pkt->pkt.comment->data, s);
- return new_kbnode( pkt );
-}
-
-
-KBNODE
-make_mpi_comment_node( const char *s, MPI a )
-{
- PACKET *pkt;
- byte *buf, *p, *pp;
- unsigned n1, nb1;
- size_t n = strlen(s);
-
- nb1 = mpi_get_nbits( a );
- p = buf = mpi_get_buffer( a, &n1, NULL );
- pkt = m_alloc_clear( sizeof *pkt );
- pkt->pkttype = PKT_COMMENT;
- pkt->pkt.comment = m_alloc( sizeof *pkt->pkt.comment + n + 2 + n1 );
- pkt->pkt.comment->len = n+1+2+n1;
- pp = pkt->pkt.comment->data;
- memcpy(pp, s, n+1);
- pp[n+1] = nb1 >> 8;
- pp[n+2] = nb1 ;
- memcpy(pp+n+3, p, n1 );
- m_free(buf);
- return new_kbnode( pkt );
-}
-
-
diff --git a/g10/main.h b/g10/main.h
index 9eb1f9635..b2bf4a468 100644
--- a/g10/main.h
+++ b/g10/main.h
@@ -198,10 +198,6 @@ MPI encode_session_key( DEK *dek, unsigned nbits );
MPI encode_md_value( int pubkey_algo, MD_HANDLE md,
int hash_algo, unsigned nbits );
-/*-- comment.c --*/
-KBNODE make_comment_node( const char *s );
-KBNODE make_mpi_comment_node( const char *s, MPI a );
-
/*-- import.c --*/
int parse_import_options(char *str,unsigned int *options,int noisy);
void import_keys( char **fnames, int nnames,
diff --git a/g10/packet.h b/g10/packet.h
index 549e8cc83..040a0a641 100644
--- a/g10/packet.h
+++ b/g10/packet.h
@@ -503,9 +503,6 @@ int handle_plaintext( PKT_plaintext *pt, md_filter_context_t *mfx,
int ask_for_detached_datafile( MD_HANDLE md, MD_HANDLE md2,
const char *inname, int textmode );
-/*-- comment.c --*/
-int write_comment( IOBUF out, const char *s );
-
/*-- sign.c --*/
int make_keysig_packet( PKT_signature **ret_sig, PKT_public_key *pk,
PKT_user_id *uid, PKT_public_key *subpk,