aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--ChangeLog7
-rw-r--r--Makefile.am2
-rw-r--r--NEWS2
-rw-r--r--configure.ac1
4 files changed, 12 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index bce8f4ef3..242239f28 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,10 @@
+2004-10-15 Werner Koch <[email protected]>
+
+ * Makefile.am (DISTCHECK_CONFIGURE_FLAGS): New.
+ (AUTOMAKE_OPTIONS): New.
+
+ * configure.ac: Check whether vasprintf needs a replacement.
+
2004-10-13 Werner Koch <[email protected]>
* configure.ac: Actually name the option --disable-finger and not
diff --git a/Makefile.am b/Makefile.am
index c6f107967..1fc16db4b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,6 +19,8 @@
## Process this file with automake to produce Makefile.in
ACLOCAL_AMFLAGS = -I m4
+DISTCHECK_CONFIGURE_FLAGS = --enable-selinux-support
+AUTOMAKE_OPTIONS = dist-bzip2 std-options
if CROSS_COMPILING
checks =
diff --git a/NEWS b/NEWS
index d2de125f2..70d805091 100644
--- a/NEWS
+++ b/NEWS
@@ -5,6 +5,8 @@ Noteworthy changes in version 1.3.91
processing of confidential files used by gpg (e.g. secring.gpg).
This helps writing ACLs for the SELinux kernel.
+ * Minor bug fixes, code and string cleanups.
+
Noteworthy changes in version 1.3.90 (2004-10-01)
------------------------------------------------
diff --git a/configure.ac b/configure.ac
index bc79f886b..8203edd9f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -799,6 +799,7 @@ AC_CHECK_FUNCS(memmove gettimeofday getrusage setrlimit clock_gettime)
AC_CHECK_FUNCS(atexit raise getpagesize strftime nl_langinfo setlocale)
AC_CHECK_FUNCS(waitpid wait4 sigaction sigprocmask rand pipe stat getaddrinfo)
AC_REPLACE_FUNCS(mkdtemp timegm)
+AC_REPLACE_FUNCS(vasprintf)
AC_CHECK_TYPES([struct sigaction, sigset_t],,,[#include <signal.h>])
# See if getopt is in libiberty. This is of course not optimal since