aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac2
-rw-r--r--tests/openpgp/Makefile.am9
2 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 57bf85e1c..d9aac71cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -820,6 +820,8 @@ if test x"$use_tofu" = xyes ; then
fi
fi
+AM_CONDITIONAL(SQLITE3, test "$have_sqlite" = "yes")
+
if test x"$use_tofu" = xyes ; then
AC_DEFINE(USE_TOFU, 1, [Enable to build the TOFU code])
fi
diff --git a/tests/openpgp/Makefile.am b/tests/openpgp/Makefile.am
index f82fc1d80..7263cd8a7 100644
--- a/tests/openpgp/Makefile.am
+++ b/tests/openpgp/Makefile.am
@@ -25,6 +25,12 @@ required_pgms = ../../g10/gpg2 ../../agent/gpg-agent \
TESTS_ENVIRONMENT = GNUPGHOME=$(abs_builddir) GPG_AGENT_INFO= LC_ALL=C
+if SQLITE3
+sqlite3_dependent_tests = tofu.test
+else
+sqlite3_dependent_tests =
+endif
+
# Note: version.test needs to be the first test to run and finish.test
# the last one
TESTS = version.test mds.test \
@@ -38,7 +44,8 @@ TESTS = version.test mds.test \
armdetachm.test detachm.test genkey1024.test \
conventional.test conventional-mdc.test \
multisig.test verify.test armor.test \
- import.test ecc.test 4gb-packet.test tofu.test \
+ import.test ecc.test 4gb-packet.test \
+ $(sqlite3_dependent_tests) \
finish.test