aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--doc/Makefile.am2
-rwxr-xr-xdoc/mksamplekeys11
2 files changed, 12 insertions, 1 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index e228f2306..9a46a0751 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -28,7 +28,7 @@ helpfiles = help.txt help.be.txt help.ca.txt help.cs.txt \
help.pt_BR.txt help.ro.txt help.ru.txt help.sk.txt \
help.sv.txt help.tr.txt help.zh_CN.txt help.zh_TW.txt
-EXTRA_DIST = samplekeys.asc \
+EXTRA_DIST = samplekeys.asc mksamplekeys \
gnupg-logo.eps gnupg-logo.pdf gnupg-logo.png gnupg-logo-tr.png\
gnupg-card-architecture.eps gnupg-card-architecture.png \
gnupg-card-architecture.pdf \
diff --git a/doc/mksamplekeys b/doc/mksamplekeys
new file mode 100755
index 000000000..bb04cec89
--- /dev/null
+++ b/doc/mksamplekeys
@@ -0,0 +1,11 @@
+#/bin/sh
+# Generate a samplekeys.asc
+
+keys='1E42B367 99242560 87978569
+ 4F25E3B6 5B0358A2 57548DCD B2D7795E 1CE0C630'
+
+for i in $keys; do
+ gpg --list-keys $i | awk ' { print " " $0 }'
+done
+echo
+gpg --export-options export-minimal --export -a $keys