aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--sm/ChangeLog7
-rw-r--r--sm/Makefile.am9
-rw-r--r--sm/server.c45
-rw-r--r--sm/sign.c4
4 files changed, 33 insertions, 32 deletions
diff --git a/sm/ChangeLog b/sm/ChangeLog
index 0a9150726..18cf83995 100644
--- a/sm/ChangeLog
+++ b/sm/ChangeLog
@@ -1,3 +1,8 @@
+2003-04-29 Werner Koch <[email protected]>
+
+ * Makefile.am: Use libassuan. Don't override LDFLAGS anymore.
+ * server.c (register_commands): Adjust for new Assuan semantics.
+
2002-12-03 Werner Koch <[email protected]>
* call-agent.c (gpgsm_agent_passwd): New.
@@ -762,7 +767,7 @@
* server.c (rc_to_assuan_status): New. Use it for all commands.
- Copyright 2001, 2002 Free Software Foundation, Inc.
+ Copyright 2001, 2002, 2003 Free Software Foundation, Inc.
This file is free software; as a special exception the author gives
unlimited permission to copy and/or distribute it, with or without
diff --git a/sm/Makefile.am b/sm/Makefile.am
index 5c137fbb8..adbcb2cdb 100644
--- a/sm/Makefile.am
+++ b/sm/Makefile.am
@@ -1,4 +1,4 @@
-# Copyright (C) 2001, 2002 Free Software Foundation, Inc.
+# Copyright (C) 2001, 2002, 2003 Free Software Foundation, Inc.
#
# This file is part of GnuPG.
#
@@ -24,8 +24,7 @@ INCLUDES = -I../intl -DLOCALEDIR=\"$(localedir)\"
bin_PROGRAMS = gpgsm
AM_CPPFLAGS = -I$(top_srcdir)/common -I$(top_srcdir)/intl \
- $(LIBGCRYPT_CFLAGS) $(KSBA_CFLAGS)
-LDFLAGS = @LDFLAGS@
+ $(LIBGCRYPT_CFLAGS) $(LIBASSUAN_CFLAGS) $(KSBA_CFLAGS)
gpgsm_SOURCES = \
gpgsm.c gpgsm.h \
@@ -51,7 +50,7 @@ gpgsm_SOURCES = \
certreqgen.c
-gpgsm_LDADD = ../jnlib/libjnlib.a ../assuan/libassuan.a ../kbx/libkeybox.a \
- ../common/libcommon.a $(LIBGCRYPT_LIBS) $(KSBA_LIBS)
+gpgsm_LDADD = ../jnlib/libjnlib.a ../kbx/libkeybox.a ../common/libcommon.a \
+ $(LIBGCRYPT_LIBS) $(LIBASSUAN_LIBS) $(KSBA_LIBS)
diff --git a/sm/server.c b/sm/server.c
index e8200feda..9fc2cd078 100644
--- a/sm/server.c
+++ b/sm/server.c
@@ -1,5 +1,5 @@
/* server.c - Server mode and main entry point
- * Copyright (C) 2001, 2002 Free Software Foundation, Inc.
+ * Copyright (C) 2001, 2002, 2003 Free Software Foundation, Inc.
*
* This file is part of GnuPG.
*
@@ -27,8 +27,9 @@
#include <ctype.h>
#include <unistd.h>
+#include <assuan.h>
+
#include "gpgsm.h"
-#include "../assuan/assuan.h"
#define set_error(e,t) assuan_set_error (ctx, ASSUAN_ ## e, (t))
@@ -719,34 +720,30 @@ register_commands (ASSUAN_CONTEXT ctx)
{
static struct {
const char *name;
- int cmd_id;
int (*handler)(ASSUAN_CONTEXT, char *line);
} table[] = {
- { "RECIPIENT", 0, cmd_recipient },
- { "SIGNER", 0, cmd_signer },
- { "ENCRYPT", 0, cmd_encrypt },
- { "DECRYPT", 0, cmd_decrypt },
- { "VERIFY", 0, cmd_verify },
- { "SIGN", 0, cmd_sign },
- { "IMPORT", 0, cmd_import },
- { "EXPORT", 0, cmd_export },
- { "", ASSUAN_CMD_INPUT, NULL },
- { "", ASSUAN_CMD_OUTPUT, NULL },
- { "MESSAGE", 0, cmd_message },
- { "LISTKEYS", 0, cmd_listkeys },
- { "LISTSECRETKEYS", 0, cmd_listsecretkeys },
- { "GENKEY", 0, cmd_genkey },
- { "DELKEYS", 0, cmd_delkeys },
+ { "RECIPIENT", cmd_recipient },
+ { "SIGNER", cmd_signer },
+ { "ENCRYPT", cmd_encrypt },
+ { "DECRYPT", cmd_decrypt },
+ { "VERIFY", cmd_verify },
+ { "SIGN", cmd_sign },
+ { "IMPORT", cmd_import },
+ { "EXPORT", cmd_export },
+ { "INPUT", NULL },
+ { "OUTPUT", NULL },
+ { "MESSAGE", cmd_message },
+ { "LISTKEYS", cmd_listkeys },
+ { "LISTSECRETKEYS",cmd_listsecretkeys },
+ { "GENKEY", cmd_genkey },
+ { "DELKEYS", cmd_delkeys },
{ NULL }
};
- int i, j, rc;
+ int i, rc;
- for (i=j=0; table[i].name; i++)
+ for (i=0; table[i].name; i++)
{
- rc = assuan_register_command (ctx,
- table[i].cmd_id? table[i].cmd_id
- : (ASSUAN_CMD_USER + j++),
- table[i].name, table[i].handler);
+ rc = assuan_register_command (ctx, table[i].name, table[i].handler);
if (rc)
return rc;
}
diff --git a/sm/sign.c b/sm/sign.c
index 061dfeebc..e58699476 100644
--- a/sm/sign.c
+++ b/sm/sign.c
@@ -101,8 +101,8 @@ hash_and_copy_data (int fd, GCRY_MD_HD md, KsbaWriter writer)
fclose (fp);
if (!any)
{
- /* We can't allow to sign an empty message becuase it does not
- make mnuch sense and more seriously, ksba-cms_build has
+ /* We can't allow to sign an empty message because it does not
+ make much sense and more seriously, ksba-cms_build has
already written the tag for data and now expects an octet
string but an octet string of zeize 0 is illegal. */
log_error ("cannot sign an empty message\n");