aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--dirmngr/Makefile.am5
-rw-r--r--dirmngr/dns-stuff.c4
2 files changed, 7 insertions, 2 deletions
diff --git a/dirmngr/Makefile.am b/dirmngr/Makefile.am
index 8cb1bb761..0d4400fad 100644
--- a/dirmngr/Makefile.am
+++ b/dirmngr/Makefile.am
@@ -128,7 +128,7 @@ endif
# http tests
-t_http_SOURCES = t-http.c http.c
+t_http_SOURCES = t-http.c http.c dns-stuff.c
t_http_CFLAGS = -DWITHOUT_NPTH=1 \
$(LIBGCRYPT_CFLAGS) $(NTBTLS_CFLAGS) $(LIBGNUTLS_CFLAGS) \
$(GPG_ERROR_CFLAGS)
@@ -136,7 +136,8 @@ t_http_LDADD = $(t_common_ldadd) \
$(NTBTLS_LIBS) $(LIBGNUTLS_LIBS) $(DNSLIBS)
t_ldap_parse_uri_SOURCES = \
- t-ldap-parse-uri.c ldap-parse-uri.c ldap-parse-uri.h http.c \
+ t-ldap-parse-uri.c ldap-parse-uri.c ldap-parse-uri.h \
+ http.c dns-stuff.c \
$(ldap_url) $(t_common_src)
t_ldap_parse_uri_CFLAGS = -DWITHOUT_NPTH=1
t_ldap_parse_uri_LDADD = $(ldaplibs) $(t_common_ldadd)
diff --git a/dirmngr/dns-stuff.c b/dirmngr/dns-stuff.c
index 00d2b3ee1..3fa6054d3 100644
--- a/dirmngr/dns-stuff.c
+++ b/dirmngr/dns-stuff.c
@@ -46,6 +46,10 @@
# include <adns.h>
#endif
+#if !defined(HAVE_GETADDRINFO) && !defined(USE_ADNS)
+# error Either getaddrinfo or the ADNS libary is required.
+#endif
+
#include "util.h"
#include "host2net.h"
#include "dns-stuff.h"