aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--cipher/ChangeLog6
-rw-r--r--cipher/cipher.c16
-rw-r--r--cipher/md.c4
3 files changed, 22 insertions, 4 deletions
diff --git a/cipher/ChangeLog b/cipher/ChangeLog
index 314005540..2441614e3 100644
--- a/cipher/ChangeLog
+++ b/cipher/ChangeLog
@@ -1,3 +1,9 @@
+2003-02-21 David Shaw <[email protected]>
+
+ * cipher.c (setup_cipher_table): #ifdef all optional ciphers.
+
+ * md.c (load_digest_module): #ifdef all optional digests.
+
2003-02-11 David Shaw <[email protected]>
* Makefile.am, md.c (load_digest_module): Only build in SHA384/512
diff --git a/cipher/cipher.c b/cipher/cipher.c
index 4bbef9377..ff19219e4 100644
--- a/cipher/cipher.c
+++ b/cipher/cipher.c
@@ -85,10 +85,9 @@ dummy_decrypt_block( void *c, byte *outbuf, byte *inbuf ) { BUG(); }
static void
setup_cipher_table(void)
{
+ int i=0;
- int i;
-
- i = 0;
+#ifdef USE_AES
cipher_table[i].algo = CIPHER_ALGO_RIJNDAEL;
cipher_table[i].name = rijndael_get_info( cipher_table[i].algo,
&cipher_table[i].keylen,
@@ -122,6 +121,9 @@ setup_cipher_table(void)
if( !cipher_table[i].name )
BUG();
i++;
+#endif
+
+#ifdef USE_TWOFISH
cipher_table[i].algo = CIPHER_ALGO_TWOFISH;
cipher_table[i].name = twofish_get_info( cipher_table[i].algo,
&cipher_table[i].keylen,
@@ -133,6 +135,9 @@ setup_cipher_table(void)
if( !cipher_table[i].name )
BUG();
i++;
+#endif
+
+#ifdef USE_BLOWFISH
cipher_table[i].algo = CIPHER_ALGO_BLOWFISH;
cipher_table[i].name = blowfish_get_info( cipher_table[i].algo,
&cipher_table[i].keylen,
@@ -144,6 +149,9 @@ setup_cipher_table(void)
if( !cipher_table[i].name )
BUG();
i++;
+#endif
+
+#ifdef USE_CAST5
cipher_table[i].algo = CIPHER_ALGO_CAST5;
cipher_table[i].name = cast5_get_info( cipher_table[i].algo,
&cipher_table[i].keylen,
@@ -155,6 +163,8 @@ setup_cipher_table(void)
if( !cipher_table[i].name )
BUG();
i++;
+#endif
+
cipher_table[i].algo = CIPHER_ALGO_3DES;
cipher_table[i].name = des_get_info( cipher_table[i].algo,
&cipher_table[i].keylen,
diff --git a/cipher/md.c b/cipher/md.c
index 1b139568c..0e5f5f8cd 100644
--- a/cipher/md.c
+++ b/cipher/md.c
@@ -96,7 +96,7 @@ load_digest_module (void)
/* We load them in reverse order so that the most
frequently used are the first in the list. */
-#ifdef USE_TIGER
+#ifdef USE_TIGER192
if (!new_list_item (DIGEST_ALGO_TIGER, tiger_get_info))
BUG();
#endif
@@ -106,8 +106,10 @@ load_digest_module (void)
if (!new_list_item (DIGEST_ALGO_SHA384, sha384_get_info))
BUG ();
#endif
+#ifdef USE_SHA256
if (!new_list_item (DIGEST_ALGO_SHA256, sha256_get_info))
BUG ();
+#endif
if (!new_list_item (DIGEST_ALGO_MD5, md5_get_info))
BUG ();
if (!new_list_item (DIGEST_ALGO_RMD160, rmd160_get_info))