diff options
Diffstat (limited to '')
-rw-r--r-- | ChangeLog | 6 | ||||
-rw-r--r-- | configure.ac | 4 |
2 files changed, 8 insertions, 2 deletions
@@ -1,3 +1,9 @@ +2006-02-18 David Shaw <[email protected]> + + * configure.ac: Try linking the UINT64_C test program (rather than + just compiling it) as UINT64_C looks like a (missing) function, + causing a false positive. Noted by Claus Assmann. + 2006-02-14 Werner Koch <[email protected]> Released 1.4.3rc1. diff --git a/configure.ac b/configure.ac index cd28ab81c..d1e4aee48 100644 --- a/configure.ac +++ b/configure.ac @@ -817,9 +817,9 @@ AC_CHECK_SIZEOF(unsigned long) AC_CHECK_SIZEOF(unsigned long long) # Ensure that we have UINT64_C before we bother to check for uint64_t -gt_HEADER_INTTYPES_H +AC_CHECK_HEADERS([inttypes.h]) AC_CACHE_CHECK([for UINT64_C], [gnupg_cv_uint64_c_works], - AC_COMPILE_IFELSE(AC_LANG_PROGRAM([#include <inttypes.h>],[ + AC_LINK_IFELSE(AC_LANG_PROGRAM([#include <inttypes.h>],[ uint64_t foo=UINT64_C(42);]),gnupg_cv_uint64_c_works=yes,gnupg_cv_uint64_c_works=no)) if test "$gnupg_cv_uint64_c_works" = "yes" ; then |